Post Reply

[Recovery] Unofficial TWRP - peregrine

OP Darkshado

4th October 2014, 11:53 AM   |  #171  
Flag Tomsk
Thanks Meter: 15
40 posts
Join Date:Joined: Jun 2011
Originally Posted by SoulSeekerHS

All my cards are recognized now, but only for a bit. After copying 2-3 files or during restore of big partition like system or data, the copy or restore will fail and the card be shown as empty. Trying to remount it will fail. Only a twrp restart will help.

This is true for Sandisk 32gb class 10, Sandisk 8GB Class 4 as well a NoName 2gb Class 4...

I had such issue with stock firmware on EU .46 firmware (without latest OTA .56). When I copied photos from internal storage to sdcard, it failed. And card didn't work until reboot. I don't remember, maybe I tried hotplug and then it worked without reboot. You could try it if TWRP support hotplug.
4th October 2014, 08:00 PM   |  #172  
rkuijpers's Avatar
Senior Member
Thanks Meter: 435
918 posts
Join Date:Joined: Aug 2010
I thought something went wrong when I updated to 21.11.56. My Sandisk Ultra 32 Gb micro sd didn't work before the update, but it only partly seemed to work after the update.

Also the same 1970 date failure happened, and the backup speed was slower than with my 16 Gb class 4 micro sd.

So as I thought the update must have failed somehow, I just restored my last backup before the update, and put in my old micro sd card. Haven't tried the update again.

But if I understand right, it could have been TWRP causing all this, and not the 21.11.56 update?

Maybe I need to try the update and my Sandisk Ultra again, using the older TWRP that worked flawlessly before.

I do hope it will work, it's a shame I can't use my super fast new micro sd card yet.

Thanks for sharing guys, I wouldn't have thought of this without your responses![emoji106]

Verstuurd vanaf mijn XT1039 met Tapatalk
4th October 2014, 09:28 PM   |  #173  
Thanks Meter: 7
45 posts
Join Date:Joined: Nov 2007
I will try downgrading to twrp 2.7 when I get a chance. Thanks for the tip.

Sent from my XT1039 using XDA Free mobile app
5th October 2014, 01:29 AM   |  #174  
Darkshado's Avatar
OP Senior Member
Thanks Meter: 464
993 posts
Join Date:Joined: Apr 2011
Donate to Me
Just a quick reminder when discussing issues, please post which build you are talking about, since there are many throughout this thread.


The Following User Says Thank You to Darkshado For This Useful Post: [ View ]
5th October 2014, 01:05 PM   |  #175  
Senior Member
Thanks Meter: 17
115 posts
Join Date:Joined: May 2013
Originally Posted by Darkshado

Just a quick reminder when discussing issues, please post which build you are talking about, since there are many throughout this thread.



I believe mine was labeled as recoverytwrp2-8NoThrottle.img, unsure where it is in this thread.
Also, what's the difference between a throttled twrp versus the non-throttled one?
Originally Posted by Zyquil

Mine also dates the back-ups with 1970-xx-xx, but I don't mind since I usually add name indicators as to what the back-up is for.
Luckily it supports my generic Class 4 32GB sdcard.

6th October 2014, 11:11 PM   |  #176  
exadeci's Avatar
Senior Member
Flag Paris
Thanks Meter: 127
524 posts
Join Date:Joined: Jul 2010
Thumbs up
Originally Posted by Somcom3X

New update, ^ new kernel change.

More sd compatibility.

THANK YOU ! At last a 4G recovery that really works
Last edited by exadeci; 6th October 2014 at 11:14 PM.
8th October 2014, 03:05 PM   |  #177  
Flag Tomsk
Thanks Meter: 15
40 posts
Join Date:Joined: Jun 2011

[s]Well, it seems that none of recoveris I found here worked on my phone. First of all, I tired to make backup on internal storage (works fine and fast) and USB-OTG (also works fine and fast).

I found 5 builds and named it like this:


There's a date of post where I downloaded it and the name of creator. I tried all of those recoveries. Two of them didn't show my sd card at all (0MB, twrp- and twrp-

On one build (twrp- "data" backup was OK. Then I tried to make "system" and "data" backup and it didn't worked. The same problem was with two other builds (2.8 with no throttle and 2.7 by darkshado). 2.8 with no throttle shows error that build failed. 2.7 version worked very slwoly and md5sum of system partition never ended (at least, I can't wait). I made error logs, may be it will help to developers. If it will help, I can make test and make another logs.

I tried two of my sd cards, Sandisk 16Gb and 8Gb class 10. I will try another one soon and will write the result.

I checked some things.
First of all, 16GB Sandisk is class 10 (I bought it specially for phone), Sandisk 8GB (which worked on my old LG P500 a lot of time) is UHS I.
I also tried Transcend class 6 8GB and backup was OK (on 2.8 no throttle)

And I checked files created by different version of backups and it seems that the best version that really worked and created big files was twrp- md5 for system.img wasn't created (I think it was because of low speed, I just turned off the phone). Other 2.7 version didn't created full backup,but showed that backup was created (the progress bar (files and percent displayed normally, only 2.8 no throttle shoed that it failed to make backup and card wasn't available). But all files was less than 100MB (system.img).

Sorry for my English. Sadly that my class 10 Sandisk don't work properly. I think that they also don't work properly on stock ROM (at least on .46, didn't check .56 OTA update).[/s]

I'm sorry that I'm writing too much. Well, again, I've made some tests and saved all logs that I found. Here's the result.
1. TWRP 2.7 by somcom3x from 18 Aug and 2.8 with throttle didn't detect any sd card.
2. None of my Sandisk cards worked on 2.8 - backup failed
3. Again, Sandisk: it worked with issues on (by darkshado from 17 Jul and by somcom3x from 2 Aug) - md5 of system generated too much time
4. Transcend class 6 worked fine on builds where SD card detected.

As I understand, this is the kernel problem. Every time it's the same issue, but results on 2.7 and 2.8 are different. I attach the logs and the file with description of results. I hope it could help developers. I'm ready to test new builds and provide log files.
Attached Files
File Type: 7z recovery-logs.7z - [Click for QR Code] (71.0 KB, 0 views)
File Type: 7z recovery-logs-new.7z - [Click for QR Code] (134.3 KB, 1 views)
Last edited by kirokko; 8th October 2014 at 05:52 PM.

The Following User Says Thank You to kirokko For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Top Threads in Moto G 4G Android Development by ThreadRank