Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Recovery] Unofficial TWRP 2.7.1.0 - peregrine

OP Darkshado

4th October 2014, 12:53 PM   |  #171  
Member
Flag Tomsk
Thanks Meter: 16
 
40 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by SoulSeekerHS

All my cards are recognized now, but only for a bit. After copying 2-3 files or during restore of big partition like system or data, the copy or restore will fail and the card be shown as empty. Trying to remount it will fail. Only a twrp restart will help.

This is true for Sandisk 32gb class 10, Sandisk 8GB Class 4 as well a NoName 2gb Class 4...

I had such issue with stock firmware on EU .46 firmware (without latest OTA .56). When I copied photos from internal storage to sdcard, it failed. And card didn't work until reboot. I don't remember, maybe I tried hotplug and then it worked without reboot. You could try it if TWRP support hotplug.
4th October 2014, 09:00 PM   |  #172  
rkuijpers's Avatar
Senior Member
Thanks Meter: 441
 
922 posts
Join Date:Joined: Aug 2010
More
I thought something went wrong when I updated to 21.11.56. My Sandisk Ultra 32 Gb micro sd didn't work before the update, but it only partly seemed to work after the update.

Also the same 1970 date failure happened, and the backup speed was slower than with my 16 Gb class 4 micro sd.

So as I thought the update must have failed somehow, I just restored my last backup before the update, and put in my old micro sd card. Haven't tried the update again.

But if I understand right, it could have been TWRP 2.8.0.0 causing all this, and not the 21.11.56 update?

Maybe I need to try the update and my Sandisk Ultra again, using the older TWRP 2.7.1.0 that worked flawlessly before.

I do hope it will work, it's a shame I can't use my super fast new micro sd card yet.

Thanks for sharing guys, I wouldn't have thought of this without your responses![emoji106]

Verstuurd vanaf mijn XT1039 met Tapatalk
4th October 2014, 10:28 PM   |  #173  
Member
Thanks Meter: 7
 
46 posts
Join Date:Joined: Nov 2007
I will try downgrading to twrp 2.7 when I get a chance. Thanks for the tip.

Sent from my XT1039 using XDA Free mobile app
5th October 2014, 02:29 AM   |  #174  
Darkshado's Avatar
OP Senior Member
Montréal
Thanks Meter: 469
 
996 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Just a quick reminder when discussing issues, please post which build you are talking about, since there are many throughout this thread.

Thanks,

Darkshado
The Following User Says Thank You to Darkshado For This Useful Post: [ View ]
5th October 2014, 02:05 PM   |  #175  
Senior Member
Thanks Meter: 28
 
142 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by Darkshado

Just a quick reminder when discussing issues, please post which build you are talking about, since there are many throughout this thread.

Thanks,

Darkshado

Apologies.
I believe mine was labeled as recoverytwrp2-8NoThrottle.img, unsure where it is in this thread.
Also, what's the difference between a throttled twrp versus the non-throttled one?
Quote:
Originally Posted by Zyquil

Mine also dates the back-ups with 1970-xx-xx, but I don't mind since I usually add name indicators as to what the back-up is for.
Luckily it supports my generic Class 4 32GB sdcard.

7th October 2014, 12:11 AM   |  #176  
exadeci's Avatar
Senior Member
Flag Paris
Thanks Meter: 131
 
529 posts
Join Date:Joined: Jul 2010
More
Thumbs up
Quote:
Originally Posted by Somcom3X

https://drive.google.com/file/d/0B8G...it?usp=sharing

New update, ^ new kernel change.

More sd compatibility.

THANK YOU ! At last a 4G recovery that really works
Last edited by exadeci; 7th October 2014 at 12:14 AM.
The Following User Says Thank You to exadeci For This Useful Post: [ View ]
8th October 2014, 04:05 PM   |  #177  
Member
Flag Tomsk
Thanks Meter: 16
 
40 posts
Join Date:Joined: Jun 2011
More
Hello!

[s]Well, it seems that none of recoveris I found here worked on my phone. First of all, I tired to make backup on internal storage (works fine and fast) and USB-OTG (also works fine and fast).

I found 5 builds and named it like this:
Quote:

twrp-2.7.1.0-peregrine-20140716-darkshado.img
twrp-2.7.1.0-peregrine-20140802-somcom3x.img
twrp-2.7.1.0-peregrine-20140818-somcom3x.img
twrp-2.8.0.0-peregrine-20140917-throttle.img
twrp-2.8.0.0-peregrine-20140918-nothrottle.img

There's a date of post where I downloaded it and the name of creator. I tried all of those recoveries. Two of them didn't show my sd card at all (0MB, twrp-2.8.0.0-peregrine-20140917-throttle and twrp-2.7.1.0-peregrine-20140818-somcom3x).

On one build (twrp-2.7.1.0-peregrine-20140802-somcom3x) "data" backup was OK. Then I tried to make "system" and "data" backup and it didn't worked. The same problem was with two other builds (2.8 with no throttle and 2.7 by darkshado). 2.8 with no throttle shows error that build failed. 2.7 version worked very slwoly and md5sum of system partition never ended (at least, I can't wait). I made error logs, may be it will help to developers. If it will help, I can make test and make another logs.

I tried two of my sd cards, Sandisk 16Gb and 8Gb class 10. I will try another one soon and will write the result.

UPDATE:
I checked some things.
First of all, 16GB Sandisk is class 10 (I bought it specially for phone), Sandisk 8GB (which worked on my old LG P500 a lot of time) is UHS I.
I also tried Transcend class 6 8GB and backup was OK (on 2.8 no throttle)

And I checked files created by different version of backups and it seems that the best version that really worked and created big files was twrp-2.7.1.0-peregrine-20140802-somcom3x.img. md5 for system.img wasn't created (I think it was because of low speed, I just turned off the phone). Other 2.7 version didn't created full backup,but showed that backup was created (the progress bar (files and percent displayed normally, only 2.8 no throttle shoed that it failed to make backup and card wasn't available). But all files was less than 100MB (system.img).

Sorry for my English. Sadly that my class 10 Sandisk don't work properly. I think that they also don't work properly on stock ROM (at least on .46, didn't check .56 OTA update).[/s]


UPDATE2:
I'm sorry that I'm writing too much. Well, again, I've made some tests and saved all logs that I found. Here's the result.
1. TWRP 2.7 by somcom3x from 18 Aug and 2.8 with throttle didn't detect any sd card.
2. None of my Sandisk cards worked on 2.8 - backup failed
3. Again, Sandisk: it worked with issues on 2.7.1.0 (by darkshado from 17 Jul and by somcom3x from 2 Aug) - md5 of system generated too much time
4. Transcend class 6 worked fine on builds where SD card detected.

As I understand, this is the kernel problem. Every time it's the same issue, but results on 2.7 and 2.8 are different. I attach the logs and the file with description of results. I hope it could help developers. I'm ready to test new builds and provide log files.
Attached Files
File Type: 7z recovery-logs.7z - [Click for QR Code] (71.0 KB, 4 views)
File Type: 7z recovery-logs-new.7z - [Click for QR Code] (134.3 KB, 5 views)
Last edited by kirokko; 8th October 2014 at 06:52 PM.
The Following User Says Thank You to kirokko For This Useful Post: [ View ]
22nd October 2014, 04:51 AM   |  #178  
agusaon's Avatar
Member
Thanks Meter: 9
 
53 posts
Join Date:Joined: Nov 2013
Hi! I'm using recoverytwrp2-8NoThrottle.img and I can't backup to the Internal Storage. I'm getting this error:

Quote:

E: Unable to create folder: /data/media/0/TWRP (errno=13)
E: Failed to make backup folder.

Anyway in SD Card it's working just fine. Thanks in advance!
22nd October 2014, 07:15 AM   |  #179  
NWKENT's Avatar
Senior Member
Thanks Meter: 504
 
1,201 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by agusaon

Hi! I'm using recoverytwrp2-8NoThrottle.img and I can't backup to the Internal Storage. I'm getting this error:



Anyway in SD Card it's working just fine. Thanks in advance!

Oooppss..sorry..wrong thread..deleted..

"Praise Jah" YOU people.!
Last edited by NWKENT; 22nd October 2014 at 07:18 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes