FORUMS

[Q] Not able to update from 4.4.4 to 5.0 via OTA

259 posts
Thanks Meter: 25
 
By lcc014, Senior Member on 5th March 2015, 12:57 PM
Post Reply Subscribe to Thread Email Thread
I purchased my Moto G (unlocked, 4.4.4) from Amazon. It was a Telus CA phone. I rooted the phone and installed CWM recovery. Last night, I got notification from Telus that 5.0 update was available for download. I downloaded it and tried to install. It kept failing for the same reason - Moto Blur version did not match. Update script repeated itself (installation) for 3 to 4 times then it stopped. So far, my phone is still at 4.4.4 and not rooted. Here is my phone's information:

Android version: 4.4.4
Baseband version: NSM8626BP_1032.390.81.01P, TELUS_CUST
Kernel: 3.4.42-gb7b2f25 hudsoncm@ilclbld54 #1 Tue Jul 15 14:12:39 CDT 2014
System: 210.12.50.falcon_umts.Telus.en.CA
Build Number: KXB21.14-L1.50

New version (5.0) available for download: 220.21.32.en.CA

Is there anyway to skip the Moto Blur version check so that update can be installed ?

Thanks,

Ching-Ho Cheng
Last edited by lcc014; 5th March 2015 at 06:24 PM.
 
 
5th March 2015, 11:47 PM |#2  
OP Senior Member
Thanks Meter: 25
 
More
Problem solved by flashing stock recovery. I was using CWM recovery. Update via OTA without problem.
8th March 2015, 07:13 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Do you have a link of where to get stock recovery and how to flash it?
8th March 2015, 07:40 AM |#4  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 2,014
 
More
The stock recovery is contained in the xml.zip file. The recovery can be flashed using fastboot or mfastboot commands.
9th March 2015, 01:38 PM |#5  
OP Senior Member
Thanks Meter: 25
 
More
Quote:
Originally Posted by docnetwork

Do you have a link of where to get stock recovery and how to flash it?

Here is the link where I got the stock firmware : http://www.filefactory.com/file/z4rk...FC_1FF.xml.zip

Unzip the .zip file and flash stock recovery using fastboot.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes