Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Can't go back to stock :(((

OP ekabon

2nd July 2014, 06:47 PM   |  #1  
ekabon's Avatar
OP Senior Member
Thanks Meter: 11
 
258 posts
Join Date:Joined: Aug 2012
Hi guys. I've been struggling with going back to stock for ages... Been flashing different firmware like 100 times... But always get the same error: "max_sparse_size 256Mb"... Or something like that... It happens when I flash system bits through fastboot or mfastboot. My model is 1032 UK unlocked. On CM snapshot at the moment. If anyone has managed to break through this problem, please help me. Thanks in advance.

Sent from my HTC One_M8 using Tapatalk
2nd July 2014, 07:16 PM   |  #2  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 74
 
312 posts
Join Date:Joined: Jun 2007
Donate to Me
More
Quote:
Originally Posted by ekabon

Hi guys. I've been struggling with going back to stock for ages... Been flashing different firmware like 100 times... But always get the same error: "max_sparse_size 256Mb"... Or something like that... It happens when I flash system bits through fastboot or mfastboot. My model is 1032 UK unlocked. On CM snapshot at the moment. If anyone has managed to break through this problem, please help me. Thanks in advance.

Sent from my HTC One_M8 using Tapatalk

Try this with mfastboot (not the normal one).

mfastboot format system
mfastboot format userdata
mfastboot format cache

or

mfastboot format /system
mfastboot format /userdata
mfastboot format /cache


If nothing happens or it says the path is incorrect use these

mfastboot format /dev/block/platform/msm_sdcc.1/by-name/system
mfastboot format /dev/block/platform/msm_sdcc.1/by-name/userdata
mfastboot format /dev/block/platform/msm_sdcc.1/by-name/cache

If you succeed doing this, then try flashing stock 4.4.2 via the normal procedure and see what heppens.
The Following User Says Thank You to liveroy For This Useful Post: [ View ]
2nd July 2014, 07:18 PM   |  #3  
ekabon's Avatar
OP Senior Member
Thanks Meter: 11
 
258 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by liveroy

Try this with mfastboot (not the normal one).

mfastboot format system
mfastboot format userdata
mfastboot format cache

or

mfastboot format /system
mfastboot format /userdata
mfastboot format /cache


If nothing happens or it says the path is incorrect use these

mfastboot format /dev/block/platform/msm_sdcc.1/by-name/system
mfastboot format /dev/block/platform/msm_sdcc.1/by-name/userdata
mfastboot format /dev/block/platform/msm_sdcc.1/by-name/cache

If you succeed doing this, then try flashing stock 4.4.2 via the normal procedure and see what heppens.

Thanks for your time will do in a bit

Sent from my HTC One_M8 using Tapatalk
2nd July 2014, 07:37 PM   |  #4  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 74
 
312 posts
Join Date:Joined: Jun 2007
Donate to Me
More
Quote:
Originally Posted by ekabon

Thanks for your time will do in a bit

Sent from my HTC One_M8 using Tapatalk

Now I`ve also notice you got error when flashing the /system
It could be that you input wrong filename, because most guides I've seen are okay but ppl copy-paste the commands w/o even checking the actual file names of the chunk files.

For most 4.4.x stock roms these are:

system.img_sparsechunk.0
system.img_sparsechunk.1
system.img_sparsechunk.2

and in the guides they are:

system.img_sparsechunk.1 or system.img_sparsechunk1
system.img_sparsechunk.2 or system.img_sparsechunk2
system.img_sparsechunk.3 or system.img_sparsechunk3

which will cause the fastboot to always spit an error on first one.
Last edited by liveroy; 2nd July 2014 at 07:52 PM.
2nd July 2014, 07:50 PM   |  #5  
ekabon's Avatar
OP Senior Member
Thanks Meter: 11
 
258 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by liveroy

Now I`ve also notice you got error when flashing the /system
It could be that you input wrong filename, because most guides I've seen are okay but ppl copy-paste the commands w/o even checking the actual file names of the chunk files.

For most 4.4.x stock roms these are:

system.img_sparsechunk.0
system.img_sparsechunk.1
system.img_sparsechunk.2

and in the guides they are:

system.img_sparsechunk.1
system.img_sparsechunk.2
system.img_sparsechunk.3

which will cause the fastboot to always spit an error on first one.

Quote:
Originally Posted by ekabon

Thanks for your time will do in a bit

Sent from my HTC One_M8 using Tapatalk

I did try this, didn't help. And I tried doing things from your first post and it didn't work... says something about raw file system. I've attached a screenshot.
Attached Thumbnails
Click image for larger version

Name:	1.jpg
Views:	46
Size:	187.0 KB
ID:	2829127  
2nd July 2014, 08:03 PM   |  #6  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 74
 
312 posts
Join Date:Joined: Jun 2007
Donate to Me
More
huh from the screenshot I see that the /system partition is raw, which shouldn't be (or the stupid fastboot defaults to "raw" partition if ext4 is not specified ...)
What happnes when you try to flash the system chunks?
The Following User Says Thank You to liveroy For This Useful Post: [ View ]
2nd July 2014, 08:13 PM   |  #7  
ekabon's Avatar
OP Senior Member
Thanks Meter: 11
 
258 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by liveroy

huh from the screenshot I see that the /system partition is raw, which shouldn't be (or the stupid fastboot defaults to "raw" partition if ext4 is not specified ...)
What happnes when you try to flash the system chunks?

All good now!) So silly, I didn't notice that in firmware folder spareschunkes have periods before number!) And in the restoring threat they don't have them!) Thanks anyway, man!!!

Sent from my HTC One_M8 using Tapatalk
2nd July 2014, 08:23 PM   |  #8  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 74
 
312 posts
Join Date:Joined: Jun 2007
Donate to Me
More
Quote:
Originally Posted by ekabon

All good now!) So silly, I didn't notice that in firmware folder spareschunkes have periods before number!) And in the restoring threat they don't have them!) Thanks anyway, man!!!

Sent from my HTC One_M8 using Tapatalk

Glad that it worked after all

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes