Post Reply

Help me find a way

OP DeHuMaNiZeD

25th July 2014, 06:21 PM   |  #1  
DeHuMaNiZeD's Avatar
OP Senior Member
Flag jastrebarsko
Thanks Meter: 1,751
 
2,937 posts
Join Date:Joined: Feb 2011
More
So,tpday was a hard day for me. Yesterday i installed 4.4.2 GPe rom on my xt1032 and immediately got a 4.4.4 update,and of course,i updated. Tried to install aero kernel,and i ended up in a boot loop,so i tried to install a stock eu xt1032 firmware,and ended in a brick. I managed to unbrick it and install a custom rom (i can post a tutorial on unbricking if you guys want) but,i want to install stock xt1032 firmware,but when i try to flash it,it's constantly giving errors. For instance, gpt.bin always throws an error,and i have to flash a custom rom again. Can anyone help? Thanks in advantage

Sent from my Moto G using Tapatalk
25th July 2014, 07:17 PM   |  #2  
Member
Flag Guadalajara
Thanks Meter: 16
 
64 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by DeHuMaNiZeD

So,tpday was a hard day for me. Yesterday i installed 4.4.2 GPe rom on my xt1032 and immediately got a 4.4.4 update,and of course,i updated. Tried to install aero kernel,and i ended up in a boot loop,so i tried to install a stock eu xt1032 firmware,and ended in a brick. I managed to unbrick it and install a custom rom (i can post a tutorial on unbricking if you guys want) but,i want to install stock xt1032 firmware,but when i try to flash it,it's constantly giving errors. For instance, gpt.bin always throws an error,and i have to flash a custom rom again. Can anyone help? Thanks in advantage

Sent from my Moto G using Tapatalk

gpt and motoboot will give you errors, you should skip those in order to downgrade, the rest of the files should flash without problems. I have flashed stock 4.4.3, downgraded to 4.4.2, installed GPE 4.4.2 to get 4.4.4 and then I flashed 4.4.2 Germany to get stock 4.4.4. Since I upgraded to 4.4.3 I had to skip gpt and motoboot and had no issues.
The Following 2 Users Say Thank You to alresave For This Useful Post: [ View ]
25th July 2014, 08:07 PM   |  #3  
DeHuMaNiZeD's Avatar
OP Senior Member
Flag jastrebarsko
Thanks Meter: 1,751
 
2,937 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by alresave

gpt and motoboot will give you errors, you should skip those in order to downgrade, the rest of the files should flash without problems. I have flashed stock 4.4.3, downgraded to 4.4.2, installed GPE 4.4.2 to get 4.4.4 and then I flashed 4.4.2 Germany to get stock 4.4.4. Since I upgraded to 4.4.3 I had to skip gpt and motoboot and had no issues.

Thanks bro,i did not know that! Saved me a lot of nerves!

So,does anyone want a tutorial on how to succesfully downgrade?

Sent from my Moto G using Tapatalk
27th July 2014, 01:40 AM   |  #4  
DeHuMaNiZeD's Avatar
OP Senior Member
Flag jastrebarsko
Thanks Meter: 1,751
 
2,937 posts
Join Date:Joined: Feb 2011
More
edit:no,cannot install stock with this method man. i got sparsechunk errors. and i really want to boot stock rom,i'm sick of custom roms.i regret the day when i converted my moto g to GPe. if anyone has a way to return to xt1032 from 4.4.4 GPe,please share it.and for those that don't know,don't ever convert your moto g to GPe.
27th July 2014, 10:49 AM   |  #5  
Senior Member
Flag Calne
Thanks Meter: 189
 
874 posts
Join Date:Joined: Oct 2011
More
I went from GPE 4.4.4 back to stock yesterday without flashing gpt.bin and motoboot.img with no issues. I then got the official Moto 4.4.4 OTA which worked fine.

I have an unlocked UK device so I flashed the most recent UK 4.4.2 ROM (Blur_Version.176.44.1.falcon_umts.Retail.en.GB),

The sparsechunk files have different names to those mentioned in the downgrade guide though.

Here's the commands I used:

Code:
mfastboot flash logo logo.bin
mfastboot flash boot boot.img
mfastboot flash recovery recovery.img
mfastboot flash system system.img_sparsechunk.0
mfastboot flash system system.img_sparsechunk.1
mfastboot flash system system.img_sparsechunk.2
mfastboot flash modem NON-HLOS.bin
mfastboot erase modemst1 
mfastboot erase modemst2 
mfastboot flash fsg fsg.mbn
mfastboot erase cache 
mfastboot erase userdata 
mfastboot reboot
27th July 2014, 10:59 AM   |  #6  
DeHuMaNiZeD's Avatar
OP Senior Member
Flag jastrebarsko
Thanks Meter: 1,751
 
2,937 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by rec71

I went from GPE 4.4.4 back to stock yesterday without flashing gpt.bin and motoboot.img with no issues. I then got the official Moto 4.4.4 OTA which worked fine.

I have an unlocked UK device so I flashed the most recent UK 4.4.2 ROM (Blur_Version.176.44.1.falcon_umts.Retail.en.GB),

The sparsechunk files have different names to those mentioned in the downgrade guide though.

Here's the commands I used:

Code:
mfastboot flash logo logo.bin
mfastboot flash boot boot.img
mfastboot flash recovery recovery.img
mfastboot flash system system.img_sparsechunk.0
mfastboot flash system system.img_sparsechunk.1
mfastboot flash system system.img_sparsechunk.2
mfastboot flash modem NON-HLOS.bin
mfastboot erase modemst1 
mfastboot erase modemst2 
mfastboot flash fsg fsg.mbn
mfastboot erase cache 
mfastboot erase userdata 
mfastboot reboot

Yes,i know that..wierd,since i tried to flash UK rom yesterday and noting..when i try to flash sparsechunk files,it says image too large on my phone's screen..

Sent from my Moto G using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto G Q&A, Help & Troubleshooting by ThreadRank