Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

How i managed to SideLoad 4.4.4 GPE

OP Clarkiieh

30th June 2014, 03:45 AM   |  #1  
Clarkiieh's Avatar
OP Senior Member
Thanks Meter: 85
 
594 posts
Join Date:Joined: Mar 2013
After a full days of Bootloops, Errors and Stress.. I have finally figured it out!

First i tried Resoring my Moto G back to Retail UK 4.4.2, in order to flash this in the hope i would recive OTA's and 4.4.4. ( i was wrong ).
So, i went ahead a tried restoring back to Retail. using this
I kept getting Errors with System and a few others..

NOTICE: When using the fastboot method to restore/flash firmware, makesure the commands you are typing are correct to the files inside the folder, for instance the final firmware i flash using fastboot what got the captured ota to work was this offical imagewhat can be found HERE
was telling me to use the following command.. "fastboot flash system system.img" but in the firmware folder it was split into 3 sparse chunk parts so you have to type the following 1-3: (i used mfastboot v2) fastboot wouldnt work for me.
mfastboot flash system system.img_sparsechunk1
mfastboot flash system system.img_sparsechunk2
mfastboot flash system system.img_sparsechunk3
(I did get a few errors stating 2&3 parts has issues with signitures. Its OKAY)
Also there is no "fastboot flash fsg fsg_gpe.img" in the Offical Firmware (if your outside the US) So just use the one already flashed, it should be okay, the new update has a new one i think because it isn't showing as 3G no more it is showing as H & H+ .

Once you have typed all the commands needed, you should have a working OFFICAL GPE ROM.

HERES WHERE THE UPDATE/SIDELOAD COMES IN!
Note, i didn't find this out myself... credits go to someone else i just noticed it and though hey ill try that, if your that guy Thanks!
Okay when your phone successfully boots. TURN IT OFF BEFORE GOING THROUGH ANY OF THE SETUP... DO NOT EVEN SELECT A LANGUAGE!
Use minimal adb & fasboot, and move the 4.4.4 GPE captured OTA to the folder, It will be located... C:/Program Files/ Minimal adb & fastboot
You need to boot into STOCK recovery it should be installed since you have just flashed stock firmware, enter fastboot and select recovery. you will see a dead droid.. just hold-in both Vol + & - and power for a few secound and release.. it will get you into the menus and select install update via adb
now open the cmd window at the minmal and fastboot where the update had been moved.. and type
adb devices (to see if your phone is working in adb)
adb sideload KOT49H.M004_5-KTU84P.M003_18.zip
it should start sideloading and ... BOOM you have 4.4.4
Now hold Right sift on the folder and right click and select to start cmd window here
The Following 3 Users Say Thank You to Clarkiieh For This Useful Post: [ View ]
30th June 2014, 05:07 AM   |  #2  
Clarkiieh's Avatar
OP Senior Member
Thanks Meter: 85
 
594 posts
Join Date:Joined: Mar 2013
Sent from my XT1032 using XDA Free mobile app
Attached Thumbnails
Click image for larger version

Name:	1404097644843.jpg
Views:	46
Size:	64.7 KB
ID:	2824839   Click image for larger version

Name:	1404097653223.jpg
Views:	60
Size:	37.6 KB
ID:	2824840  
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes