Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,708 Members 52,400 Now Online
XDA Developers Android and Mobile Development Forum

Recover a 4.4.4 downgrade brick! (Temporal solution)

Tip us?
 
nl2008
Old
#41  
nl2008's Avatar
Senior Member
Thanks Meter 7
Posts: 160
Join Date: Jul 2008
Finally got reception working after start everything again..Comfirmed this method really works...just need original fsg.mbn file from ORIGINAL rom that ship with the phone to flash modem. Also TWRP recovery + gpt.bin above and perform the steps. Thanks to ALL. Great job!
 
psipsi
Old
#42  
Junior Member
Thanks Meter 1
Posts: 2
Join Date: Jul 2014
Quote:
Originally Posted by nl2008 View Post
Was your phone converted to gpe 4.2.2 then ota to 4.4.4 and get soft brick when downgrade back to 4.4.2 gpe? That's my phone now...got no reception, cant recognised simcard anymore..Dont know what to do...I've tried all methods...can restore to to 4.4.2 gpe or 4.4.4 but SIMCARD not recognised anymore
Yes, same situation.
 
icebeanpie
Old
#43  
icebeanpie's Avatar
Junior Member
Thanks Meter 4
Posts: 26
Join Date: May 2013
Location: Hamburg
Thumbs up You're da man!

Quote:
Originally Posted by _Drifter_ View Post
Okay, i just resolved my soft-brick (downgrade from 4.4.4 to 4.4.2). Wheres what i do:

1- Flash the gpt.bin from the first post.

2- Flash the TWRP Recovery.

3- Go to Wipe

4- Format Data

5- Type Yes

6- Advanced Wipe, do not choose anything, just swipe to wipe, when it's over just appear: ''updating partition details...''

7- I use a USB OTG with a pen and CM11 on it. Flash the ROM. In TWRP you will have a Sucessful message and a ''updating partition details...'' message as well after flashing a rom.

8- Reboot the phone.

Now, i dont know if its related but, before this, I try flashing a 4.3 ROM using this method:http://forum.xda-developers.com/show....php?t=2542219

I edit the flashall file, just delete this:

CALL :fastboot_flash partition gpt.bin
IF %errorlevel% NEQ 0 EXIT /b 1

Flash follow the tutorial, and in the fastboot in a message like this appear: version downgrade from tgz.

Then I start the #1 procedure.

Now, I dont have network working, wifi, BT, GPS works fine, no network. Probably a imei corruption?




-----------------------------------



Okay, i tried soft-brick the phone again to see which method can reverse the situation, wheres what I do to solved the sof-brick, if some dev can take a look and figure out why this solved, at least, my problem would be nice:

1- Flash TWRP, I use the OP method in the first post.

1- Try this with a 4.3 ROM: http://forum.xda-developers.com/show...php?p=49759263
Like i said, open the flashall file and delete this lines:

CALL :fastboot_flash partition gpt.bin
IF %errorlevel% NEQ 0 EXIT /b 1

The Phone, will not flash back to 4.3, but somehow, the error e:unable to mount data / system / internal storge is gonne from recovery when flashing a ROM and the phone mount data, system, cache and internal just fine. When the flash is donne, a pink message will appear in the phone: version downgraded for tgz.

2- Go to TWRP.

3- Go to Wipe.

4- Format data - type yes using the keyboard

5- Advanced Wipe - do not select any option, go to this menu and just swipe to wipe. When the process is done, it will appear a message saying: updating partition details...

6- Go to Mount - you will see data and cache mount. This point is just to see if data and cache is mount.

7- Where I used a USB OTG, but someone could try pushing the ROM using adb, I think it will work. In my case, just mount the USB OTG and flash a ROM. When the ROM is finish, the same message will appear: updating partition details...

8- Boot the phone.


Now, in my case, i do not have network, BT, Wifi, GPS works not network, so probably the EFS paste was deleted when try get the phone back to work. So, be aware, if you try this method and lost your IMEI/network, im not responsable.
Thank you so much dude, actually this is what helped me to get cm11 running! Everytime when I only flashed the gpt.bin from 4.4.4 ant then flashed the rom itself it was stuck at bootanymation - anyway I wasn't able to mount/use /data partition. Then read your post and formatted /data completely and it worket for me: I was able to use data again.

################################################## ################################################## ###################

But also many many thanks for the 4.4.4 gpt image, tatazeuz!!

This is, why I love xda, the people are all very friendly and after a bit of research you always can get a solution solving your problem
  • Unlocked
  • Rooted
Tags
4.4.4, brick, downgrade, soft, softbrick
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes