Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,628 Members 38,913 Now Online
XDA Developers Android and Mobile Development Forum

[Q] WiFi and BT Issues with Peregrine Carbon-ROM

Tip us?
 
Termuellinator
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Sep 2014
Default [Q] WiFi and BT Issues with Peregrine Carbon-ROM

Hi, i was happy seeing that the dev of the CM/Carbon/Slim-Roms didn't just stop but moved from the old original shabbypenguin-thread to xda

the latest Carbon-Build ( CARBON-KK-NIGHTLY-20140825-0209-peregrine.zip ) finally works for the most part on my side, pretty happy with that.
unfortunately 2 things aren't and i wanted to see if anyone else has this issues or has some idea to solve them

first one is, that WiFi won't connect to all networks - at home on a netgear-repeater everything is fine - in the office it won't connect to D-Link and TP-Link routers.
the other, more troubling issue is that bluetooth isn't working as it should - as long as no device is connected, everything is fine, but as soon as it connects to my car-system (MB C-Class w204 without command if that makes any difference ) the bluetooth-process stops, reconnects, stops again and so on...with my laptop everything seems to be working fine and i think the first drive after coupling also worked fine - any idea what can be the cause of this? never had this kind of problem before, be it stock or older unofficial CM-Builds etc...

i'm refering to this thread btw: http://forum.xda-developers.com/moto...itkat-t2847887

regards
 
Termuellinator
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Sep 2014
Quote:
Originally Posted by Termuellinator View Post
Hi, i was happy seeing that the dev of the CM/Carbon/Slim-Roms didn't just stop but moved from the old original shabbypenguin-thread to xda

the latest Carbon-Build ( CARBON-KK-NIGHTLY-20140825-0209-peregrine.zip ) finally works for the most part on my side, pretty happy with that.
unfortunately 2 things aren't and i wanted to see if anyone else has this issues or has some idea to solve them

first one is, that WiFi won't connect to all networks - at home on a netgear-repeater everything is fine - in the office it won't connect to D-Link and TP-Link routers.
the other, more troubling issue is that bluetooth isn't working as it should - as long as no device is connected, everything is fine, but as soon as it connects to my car-system (MB C-Class w204 without command if that makes any difference ) the bluetooth-process stops, reconnects, stops again and so on...with my laptop everything seems to be working fine and i think the first drive after coupling also worked fine - any idea what can be the cause of this? never had this kind of problem before, be it stock or older unofficial CM-Builds etc...

i'm refering to this thread btw: http://forum.xda-developers.com/moto...itkat-t2847887

regards
*push* nobody got any ideas? i would post it in the appropriate thread (especially since this rom is still only nightly) as a potential bug report, but as a new user i'm not able to :/
 
Termuellinator
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Sep 2014
just another push...somebody must have any idea on what i can try to either solve or at least track down the cause of the issue(s)
sure enough, the BT-issue is worse..

tried the newest build (dirty update and after that clean flash), but still no luck
 
Rhyn
Old
#4  
Member
Thanks Meter 47
Posts: 89
Join Date: Aug 2012
Location: Budapest
Quote:
Originally Posted by Termuellinator View Post
just another push...somebody must have any idea on what i can try to either solve or at least track down the cause of the issue(s)
sure enough, the BT-issue is worse..

tried the newest build (dirty update and after that clean flash), but still no luck
The WiFi bug is a known issue since early August. It affects almost every Moto device (G, G 4G, X and defy?) it's reported several times to CM-s bug tracking system, but nobody cares... You can use custom kernels. Maybe they aren't affected.

I don't know anything about the BT bug.
The Following User Says Thank You to Rhyn For This Useful Post: [ Click to Expand ]
 
Termuellinator
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Sep 2014
i found some posts about people having the same kind of wifi-issue, but it is good to know, that the devs are aware and - kind of - working on it

the BT-thingy is driving me insane though...fiddled around a bit, stopping BT-Related processes etc...this somehow did something...my phone now connects and stays connected, i can make phone calls...but the contact list is incomplete - only 3 random contacts are displayed on the car system
haven't rebooted since then, i kind of fear that rebooting will bring back the issue :/
 
Termuellinator
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Sep 2014
BT still working after reboot, so it seems my "fix" is permanent...must have something to do with deleting the BT-data/cache while process was killed i would think - in case someone else also encounters this problem

still can't acces all my contacts from Car-system though :/
 
juliospinoza
Old
#7  
juliospinoza's Avatar
Senior Member
Thanks Meter 75
Posts: 224
Join Date: Jan 2012
Location: Tepic
Most nights roms have a lot of issues and it is pretty hard to stay aware all of bugs. Why don't you try something more stable like Pac Man RC or some. Sometimes a different kernel will help sometimes it's the opposite.
 
Termuellinator
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Sep 2014
Well, i'd rather use a stable version for sure...
sadly, i didn't know about falcon<->peregrine, so i thought i can use all the Moto G roms with my xt1039...

and to this date there are no stable roms for peregrine that i am aware of - an old unofficial CM-Build worked pretty good for me, but CM unfortunatley doesn't offer all the features i want - carbon covers pretty much most of it, so i'm hoping that it will be "bugfree" soon enough ^^
 
Rhyn
Old
#9  
Member
Thanks Meter 47
Posts: 89
Join Date: Aug 2012
Location: Budapest
Quote:
Originally Posted by Termuellinator View Post
Well, i'd rather use a stable version for sure...
sadly, i didn't know about falcon<->peregrine, so i thought i can use all the Moto G roms with my xt1039...

and to this date there are no stable roms for peregrine that i am aware of - an old unofficial CM-Build worked pretty good for me, but CM unfortunatley doesn't offer all the features i want - carbon covers pretty much most of it, so i'm hoping that it will be "bugfree" soon enough ^^
All AOSP rom uses the CM device tree and kernel as a base, so the low level kernel bugs are the same.. Also the last "stable" CM for falcon is dated back to April, so you didn't lose anything with peregrine...

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Android M Mentions Spotted in Android Code Review

While we are still waiting for Android L to be officially released, the first mentions of … more

Create a Simple Custom Launcher from Scratch

When you are starting your journey intoany sort of development, it’s never easy at the … more

MediaTek Continues Steps Towards Being Developer-Friendly

Not too long ago MediaTek was very closed off towards the mobile developer … more