Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,619 Members 46,469 Now Online
XDA Developers Android and Mobile Development Forum

[Toolkit] Moto X Dev Edition Only for MAC OSX v2.02

Tip us?
 
mjphillips1981
Old
(Last edited by mjphillips1981; 17th April 2014 at 03:28 PM.)
#1  
mjphillips1981's Avatar
Member - OP
Thanks Meter 53
Posts: 72
Join Date: Jul 2010
Location: Youngstown, Ohio

 
DONATE TO ME
Prompt [Toolkit] Moto X Dev Edition Only for MAC OSX v2.02

Hello everyone. I just sold my Moto X so I will no longer be updating this toolkit. I will try and help anyone with questions/problems when needed.

Back by popular demand...

I have had some people asking for links for my previously deleted toolkit.

So I have decided to revamp the toolkit for dev edition devices only. (Currently only supporting GSM dev (AT&T and T-Mobile) and VZW Dev)

With this toolkit you will be able to the following...
1) Root your device (unlock bootloader, install TWRP, install superSU)
2) Unroot your device
3) Return to stock
4) Debloat (google, moto, vzw stuff)
5) Activate mobile hotspot (VZW only)
6) reboot (recovery, bootloader, device)
7) Customize (bootanimation, bootlogo, ringtones, notifications)



How to use
1) Click download below
2) Extract zip file
3) Turn you phone on
4) Make sure USB debugging is enabled
5) Plug your phone into the computer.
6) Run moto_x_mac_tools.tool
7) FOLLOW ONSCREEN INSTRUCTIONS



Screenshots
See attachments...


Download
Moto X Toolkit v2.02

Change Log
v2.01 - Fixed some bugs with restoring back to stock, removed ReadWrite status (with dev edition this status is not needed)
v2.02 - Added downgrade from 4.4.2 to 4.4
- When returning to stock, or downgrading, USER DATA will be erased (no longer an option)
- There are only 2 variants of the dev edition so I changed to Verizon and GSM



Please do not redistribute/mirror this toolkit. If you would like to link it in any other thread, please include a link back to this thread, give proper credit.

As with anything you will find on XDA, I am not responsible for anything that occurs to your phone or computer by using this toolkit.


Credits
DHacker29 / Hashcode - TWRP
Chainfire - SuperSU
imnuts - VZW tether
Google
Motorola
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2014-03-01 at 12.10.29 PM.png
Views:	790
Size:	213.7 KB
ID:	2607938   Click image for larger version

Name:	Screen Shot 2014-03-01 at 12.10.40 PM.png
Views:	641
Size:	206.5 KB
ID:	2607939   Click image for larger version

Name:	Screen Shot 2014-03-01 at 12.10.51 PM.png
Views:	578
Size:	183.8 KB
ID:	2607940   Click image for larger version

Name:	Screen Shot 2014-03-01 at 12.11.01 PM.png
Views:	590
Size:	242.3 KB
ID:	2607941  
The Following 16 Users Say Thank You to mjphillips1981 For This Useful Post: [ Click to Expand ]
 
iamjackspost
Old
#2  
Junior Member
Thanks Meter 5
Posts: 21
Join Date: Sep 2011
Awesome, I used your old toolkit to flash stock recovery (so I could take the ota) and then back to TWRP. It was so easy! I'm sure others will appreciate this as well.
 
mjphillips1981
Old
#3  
mjphillips1981's Avatar
Member - OP
Thanks Meter 53
Posts: 72
Join Date: Jul 2010
Location: Youngstown, Ohio

 
DONATE TO ME
Quote:
Originally Posted by iamjackspost View Post
Awesome, I used your old toolkit to flash stock recovery (so I could take the ota) and then back to TWRP. It was so easy! I'm sure others will appreciate this as well.
Toolkit is ready for download!!
 
moonzilla
Old
#4  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Jul 2007
Default unlock with moto first?

Do I need to unlock my bootloader with Motorola before using the toolkit? I do have a VZW Dev device, but wanted to confirm.
 
daddyshatch
Old
#5  
Member
Thanks Meter 2
Posts: 43
Join Date: Oct 2010
This utility is amazing and a must for anyone with a Mac! Thanks x100!
 
mjphillips1981
Old
#6  
mjphillips1981's Avatar
Member - OP
Thanks Meter 53
Posts: 72
Join Date: Jul 2010
Location: Youngstown, Ohio

 
DONATE TO ME
Quote:
Originally Posted by moonzilla View Post
Do I need to unlock my bootloader with Motorola before using the toolkit? I do have a VZW Dev device, but wanted to confirm.
You can either unlock before using the toolkit. Or you can use the toolkit to guide you through the unlock. If you go to root device. The 1st question is if you are unlocked or not. If not, it will guide you through the process of unlocking the bootloader (semi-automatic). Let me know if you have any questions.

Mike
 
wmjchoi
Old
(Last edited by wmjchoi; 3rd March 2014 at 08:10 AM.)
#7  
Member
Thanks Meter 4
Posts: 36
Join Date: Sep 2010
Thank you for re-posting this tool.

I am trying to go back to stock 4.4 to get the OTA (I have a Dev Ed VZN Moto X). I followed the on screen directions and downloaded the VZN 4.4 file (640 MB file). Then the phone reboots to bootloader (ReadWriteMode is 0). I press ENTER since the device has booted into FB mode and it says USB connected, the ReadWriteMode reads error: device not found (I did not unplug the phone from the computer).

Is there a fix for it? The same thing happens when I try to download 4.4.2.

Thanks
 
mjphillips1981
Old
#8  
mjphillips1981's Avatar
Member - OP
Thanks Meter 53
Posts: 72
Join Date: Jul 2010
Location: Youngstown, Ohio

 
DONATE TO ME
Quote:
Originally Posted by wmjchoi View Post
Thank you for re-posting this tool.

I am trying to go back to stock 4.4 to get the OTA (I have a Dev Ed VZN Moto X). I followed the on screen directions and downloaded the VZN 4.4 file (640 MB file). Then the phone reboots to bootloader (ReadWriteMode is 0). I press ENTER since the device has booted into FB mode and it says USB connected, the ReadWriteMode reads error: device not found (I did not unplug the phone from the computer).

Is there a fix for it? The same thing happens when I try to download 4.4.2.

Thanks
When in fastboot mode. The readwrite will say device not found. An ADB command is used to check the readwrite status. And ADB commands do not function while in fastboot mode.

You are ok to continue.
 
wmjchoi
Old
#9  
Member
Thanks Meter 4
Posts: 36
Join Date: Sep 2010
Quote:
Originally Posted by mjphillips1981 View Post
When in fastboot mode. The readwrite will say device not found. An ADB command is used to check the readwrite status. And ADB commands do not function while in fastboot mode.

You are ok to continue.
Thanks.

I pressed enter to continue but my phone just reboots and restore does not work.

But when I tried to flash the stock recovery, readwrite says 0 and works like a charm. The problem only occurs when I try to restore the device.
 
mjphillips1981
Old
#10  
mjphillips1981's Avatar
Member - OP
Thanks Meter 53
Posts: 72
Join Date: Jul 2010
Location: Youngstown, Ohio

 
DONATE TO ME
Quote:
Originally Posted by wmjchoi View Post
Thanks.

I pressed enter to continue but my phone just reboots and restore does not work.

But when I tried to flash the stock recovery, readwrite says 0 and works like a charm. The problem only occurs when I try to restore the device.
I will test on my device. I will let you know what I find out.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes