Mural Watchface Brings 500px to Android Wear

On a traditional watch, you can’t really do too much to change its appearance once … more

Android 5.0 Favorite Features, Release November 3rd? – XDA TV

Google Confirms Android 5.0 Lollipop for November 3rd! That and much more … more

Prepare Your Build Machines: Ubuntu 14.10 Utopic Unicorn Now Official

Today is an important day for any and all Linux enthusiasts. One of the … more

Track the Time You Waste on Social Media with Socials Addict

When you use your phone, you often don’t even realize how much time you … more
Post Reply

AT&T 4.4.2 Rooted Moto X unlocks after missed call

OP 97vulcan

16th June 2014, 04:51 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Mar 2014
I cannot find a solution for this but the issue is when I miss a phone call when the phone is in my pocket, it automatically unlocks, and drains my battery.

I'm running 4.4.2 rooted on my AT&T Moto X, and I thought 4.4.2 would fix it. I do not have a screen lock

Any help is appreciated.

Thanks!
16th June 2014, 07:23 PM   |  #2  
samwathegreat's Avatar
Senior Member
Thanks Meter: 1,728
 
1,988 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by 97vulcan

I cannot find a solution for this but the issue is when I miss a phone call when the phone is in my pocket, it automatically unlocks, and drains my battery.

I'm running 4.4.2 rooted on my AT&T Moto X, and I thought 4.4.2 would fix it. I do not have a screen lock

Any help is appreciated.

Thanks!

Hmm sounds like a strange issue...

You mean you don't have a screen pin/code/password, or that you don't have even the sliding unlock button?

Have a look in Settings > Display

What timeout do you have listed under sleep? The default is 30seconds, but it goes all the way up to 30min (which I would expect could definitely drain some battery...

Let us know and we may be able to help you further...
16th June 2014, 08:43 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Mar 2014
Quote:
Originally Posted by samwathegreat

Hmm sounds like a strange issue...

You mean you don't have a screen pin/code/password, or that you don't have even the sliding unlock button?

Have a look in Settings > Display

What timeout do you have listed under sleep? The default is 30seconds, but it goes all the way up to 30min (which I would expect could definitely drain some battery...

Let us know and we may be able to help you further...

I do not have a password lock on my phone, Just the active display slide to unlock the phone. When a call comes in, I get the display to answer or ignore, but if I leave it go, it will just unlock to the home screen, then after a short time, the screen will shut off.

Thanks!
17th June 2014, 03:02 AM   |  #4  
samwathegreat's Avatar
Senior Member
Thanks Meter: 1,728
 
1,988 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by 97vulcan

I do not have a password lock on my phone, Just the active display slide to unlock the phone. When a call comes in, I get the display to answer or ignore, but if I leave it go, it will just unlock to the home screen, then after a short time, the screen will shut off.

Thanks!

Ok, that is definitely not normal. Are you BL unlocked, or are you using the Pie root exploit? Or Safestrap?

I would suggest flashing the entire 4.4.2 AT&T SBF file using the manual method as described in the Return to Stock thread:

DO NOT DO THIS IF YOU ARE USING SAFESTRAP

http://forum.xda-developers.com/moto...using-t2446515

You will download the 4.4.2 AT&T SBF file from here: http://sbf.droid-developers.org/phone.php?device=0

As I seem to be telling people often, the only way to fix a corrupted filesystem (OR modifications made by previous exploits like Pwn/SlapMyMoto and MotoWpNoMo) is to flash the entire SBF file. Performing a "factory reset" cannot repair a damaged filesystem.

Often, it will fix ALL of your problems.

Good Luck
Last edited by samwathegreat; 17th June 2014 at 03:40 AM.
17th June 2014, 03:18 AM   |  #5  
ai6908's Avatar
Senior Member
Flag Land of Lincoln
Thanks Meter: 267
 
3,607 posts
Join Date:Joined: Nov 2006
Donate to Me
More
Did you install any apps, that plays with those settings after rooting?
17th June 2014, 02:41 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Mar 2014
Thumbs up
thanks for the replies guys...I don't think so on the apps after root. IIRC, it did this before rooting the phone, so I thought it was a 4.4 issue.

it will unlock to the home page after every call, unless I answer, or ignore the call.

I'm using Xposed with these modules:

App Settings
GravityBox
HideCarrierMotoX
MinMinGuard
SoftkeysFadeMod
Twisty Switch
Xblast Tools
XPrivacy.

Again, I do not have a lock screen..when I try to enable one it does something funky with my electronic buttons, even after reboot. Not sure if it's because of SoftKeysFadeMod, or what..

I'm surprised others have not had this issue.

Thanks for you help.
17th June 2014, 08:12 PM   |  #7  
rtm1102's Avatar
Junior Member
Thanks Meter: 2
 
14 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by 97vulcan

I do not have a password lock on my phone, Just the active display slide to unlock the phone. When a call comes in, I get the display to answer or ignore, but if I leave it go, it will just unlock to the home screen, then after a short time, the screen will shut off.

Thanks!

May I ask if I understand correctly? You have no security setting, only active display enabled. If this is the case, this seems like normal behavior.

You screen turns on when you get a call, you don't answer. Until the screen time out kicks in, you see your home screen.

Once it goes dark, you should have an active display notification.

What Am i missing or what behavior are you expecting?
Last edited by rtm1102; 17th June 2014 at 08:20 PM.
17th June 2014, 10:10 PM   |  #8  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Mar 2014
Quote:
Originally Posted by rtm1102

May I ask if I understand correctly? You have no security setting, only active display enabled. If this is the case, this seems like normal behavior.

You screen turns on when you get a call, you don't answer. Until the screen time out kicks in, you see your home screen.

Once it goes dark, you should have an active display notification.

What Am i missing or what behavior are you expecting?


you pretty much hit it on the head...I was hoping the phone's display would not unlock to my desktop if I miss a call, but rather show the missed call on the active display.

I'm going to enable a security setting, and see if this changes the outcome.

Thanks
18th June 2014, 09:47 PM   |  #9  
OP Junior Member
Thanks Meter: 0
 
22 posts
Join Date:Joined: Mar 2014
Thumbs up
After enabling the swipe to unlock, I no longer have an issue with my phone unlocking when I miss a call. That seems to be the solution.

Thanks for your help

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X General by ThreadRank