Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] 4.2.2 Active notifications repeat until phone unlocked

OP oc83

9th January 2014, 08:44 AM   |  #1  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Jun 2013
Moto X, 4.2.2 stock, rooted

When receiving a an email, message, or whatever (e.g., Gmail, snapchat, kakaotalk, google voice), the active notification appears as normal (vibrate/sound + screen display), but then the phone repeatedly displays the notification until it's unlocked. I do want the initial notification, but just the one. After the initial notification, further notif. only display the screen (no sound/vibrate).

When there isn't a notification, it doesn't display the clock over and over again as if I'm picking it up, so it's not like it's being moved around or something.

It did not used to do this, but I'm not sure exactly what setting/app/whatever would have caused this.

'Active notifications' has an option to disable certain apps or turn off completely, but there are no 'repeat' or 'lockscreen' settings located there, or in individual apps.

When I googled/searched for the issue (key words: active, notifications, repeat, stop, android, alert), I found these related posts, which seem to describe what I'm experiencing (albeit on different phones). Edit: ah, I can't post links yet, if you would like to look at them, please google the parts-of-the-url below

s4-active-message-notification-doesnt-stop-coming-up-lock-screen
android-kit-kat-moto-x-repeated-notifications-for-the-same-email

Has anyone else had this problem? What settings, if any, can I check for to disable these unwanted (repeated) notifications or how else might I go about it?
9th January 2014, 11:17 AM   |  #2  
DarkWolffe's Avatar
Junior Member
Thanks Meter: 4
 
27 posts
Join Date:Joined: Nov 2012
More
This isn't a bug or an issue, it's a feature. It's something called "breathing" notifications.

Every so often, the phone will give you the notification again just to be sure you saw it the first time. There is no way to remove or alter this feature through Active Display's settings.

If you are looking for an equivalent to Active Display, a good one (and the only one I know of) is DynamicNotifications by GreatBytes.
The Following User Says Thank You to DarkWolffe For This Useful Post: [ View ]
9th January 2014, 06:26 PM   |  #3  
scottjb's Avatar
Senior Member
Flag Greensboro, NC
Thanks Meter: 161
 
895 posts
Join Date:Joined: Sep 2010
More
Have you tried swiping the notification to the side? That should dismiss it.

Sent from my XT1053 using Tapatalk
The Following User Says Thank You to scottjb For This Useful Post: [ View ]
9th January 2014, 09:35 PM   |  #4  
OP Junior Member
Thanks Meter: 2
 
6 posts
Join Date:Joined: Jun 2013
It seemed to me it wasn't normal behavior, as I don't remember it happening when I first got the device, but if you say it's intended, I'll go with that.

DarkWolffe: you say "every so often". The notifications are appearing every 5 seconds or so. Is this inline with what your own experience? If I can't change that interval from the native settings, might the app you linked be able to? It seems that DynamicNotifications is made for devices that don't already have Active Notifications. (perhaps I'm supposed to disable AN and only use DN?) Thank you for the link, though, I'll check it out.

scottjb: Ah, I figured that out sometime after making this post, but thank you for that tip. It's useful when I may actually see the phone, but when I'm away from the phone or sleeping, for example, I'd prefer it not to behave that way. I realize it's an AMOLED screen, so the battery really shouldn't be affected too much, but it doesn't feel right to have it turn on over and over again so often.

Knowing they're called "breathing notifications" has allowed me to better search for related topics. It seems that turning the phone over or putting it in a pocket will stop the breathing. I'd still prefer if I could change the interval somehow, but I'm satisfied to have figured most of how it works out.
Last edited by oc83; 9th January 2014 at 09:49 PM.
9th January 2014, 10:13 PM   |  #5  
Senior Member
Langley, BC
Thanks Meter: 207
 
666 posts
Join Date:Joined: Sep 2013
The interval of the notifications seems to change over time. When you first get a text message etc it seems to flash the notifications more often, after some time I believe it slows down a little. You can have the feature disabled at night, my ringer is silent from midnight to 9 am and my active notifications are disabled from 1 to 7 am. When disabled at night it only stops it from displaying on its own, if you move the phone it will still display the clock and any notifications.
The Following User Says Thank You to Steve-x For This Useful Post: [ View ]
8th October 2014, 09:32 AM   |  #6  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2013
More
Info 2 LG Pulse with KitKat 4.4.2 same issue
I don't have a Moto X, I have the LG Pulse from Virgin Mobile Custom. My notifications do that, too! I have KitKat 4.4.2. I have never experienced this and I certainly would NOT make it a default nor intended action. Mine start out at the first notification + sounds, then 10 seconds later, 15 seconds later, 20 sec, 25 sec, etc. It is very annoying and there is no option in the system settings nor individual app settings to stop that behavior. I may just have to turn off notification sounds as this is ridiculous.
8th October 2014, 03:08 PM   |  #7  
Senior Member
Thanks Meter: 42
 
195 posts
Join Date:Joined: Mar 2009
You can try setting the "sleep at night" option, and adjust the time to be on all the time (1am to 12am).
I believe this setting is supposed to suppress the breathing notifications. Though, it won't stop it from showing if you move the phone around... I know this cause my phone charges on my bed at night and when I roll around, it triggers AD, even though I have sleep mode on.

Hope it helps!

tapa'd on my moto x
8th October 2014, 03:10 PM   |  #8  
Senior Member
Thanks Meter: 42
 
195 posts
Join Date:Joined: Mar 2009
Damn Tapatalk, won't let me edit..

tapa'd on my moto x
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1412773820878.png
Views:	28
Size:	100.6 KB
ID:	2963933  

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes