Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,749 Members 51,128 Now Online
XDA Developers Android and Mobile Development Forum

[Q] 4.4.2 Wifi hotspot turns on and devices connect, but no internet access.

Tip us?
 
csos95
Old
#1  
csos95's Avatar
Member - OP
Thanks Meter 9
Posts: 37
Join Date: Apr 2013
Default [Q] 4.4.2 Wifi hotspot turns on and devices connect, but no internet access.

I can turn on wifi hotspot in settings and connect with other devices, but they can't actually connect to the internet. I've tried moto tether in xposed, wifi tether router(with the mooto x specific settings in the app guide), foxfi, and a plethora of other generically named wifi tether apps. Nothing I try is working. My Moto X has an unlocked bootloader, twrp recovery, stock rooted 4.4.2 and I am using straight talk (runs on AT&T's network). This problem has plagued me since I got the phone and I can't seem to find any solution that actually works. Does anyone know of a solution to this?
 
samwathegreat
Old
#2  
samwathegreat's Avatar
Senior Member
Thanks Meter 354
Posts: 836
Join Date: Apr 2010
Quote:
Originally Posted by csos95 View Post
I can turn on wifi hotspot in settings and connect with other devices, but they can't actually connect to the internet. I've tried moto tether in xposed, wifi tether router(with the mooto x specific settings in the app guide), foxfi, and a plethora of other generically named wifi tether apps. Nothing I try is working. My Moto X has an unlocked bootloader, twrp recovery, stock rooted 4.4.2 and I am using straight talk (runs on AT&T's network). This problem has plagued me since I got the phone and I can't seem to find any solution that actually works. Does anyone know of a solution to this?
I had a similar issue with wifi and it was ultimately resolved by SBFing back to stock, re-trying, and it worked like a charm. You can read the whole thread here: http://forum.xda-developers.com/moto...ocked-t2755730

While we never did figure out what the issue was (because my device was completely stock, other than flashing SuperSU/TWRP), but now it works great. I'm using the WiFi Tether for root users...download link is in the thread I linked above. I know its a bit of a pain to have to reinstall your apps, etc, but it was worth it to me.

Good Luck
Remember: the "SEARCH" button will often save you a great deal of time waiting for a reply.

Help us keep XDA fun and safe. Please read the RULES, and please respect your fellow members.

Quote of the year:
Quote:
Originally Posted by doitinthedirt View Post
Well Google now doesn't work worth an iPhone. .I've spoken those last two lines ADB shell commands out loud for the past 15 minutes and I don't get root
Tags
tether, wifi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes