Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] 4.4.2 Wifi hotspot turns on and devices connect, but no internet access.

OP csos95

19th June 2014, 04:35 AM   |  #1  
csos95's Avatar
OP Member
Thanks Meter: 10
 
37 posts
Join Date:Joined: Apr 2013
I can turn on wifi hotspot in settings and connect with other devices, but they can't actually connect to the internet. I've tried moto tether in xposed, wifi tether router(with the mooto x specific settings in the app guide), foxfi, and a plethora of other generically named wifi tether apps. Nothing I try is working. My Moto X has an unlocked bootloader, twrp recovery, stock rooted 4.4.2 and I am using straight talk (runs on AT&T's network). This problem has plagued me since I got the phone and I can't seem to find any solution that actually works. Does anyone know of a solution to this?
19th June 2014, 05:15 AM   |  #2  
samwathegreat's Avatar
Senior Member
Thanks Meter: 1,790
 
2,029 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by csos95

I can turn on wifi hotspot in settings and connect with other devices, but they can't actually connect to the internet. I've tried moto tether in xposed, wifi tether router(with the mooto x specific settings in the app guide), foxfi, and a plethora of other generically named wifi tether apps. Nothing I try is working. My Moto X has an unlocked bootloader, twrp recovery, stock rooted 4.4.2 and I am using straight talk (runs on AT&T's network). This problem has plagued me since I got the phone and I can't seem to find any solution that actually works. Does anyone know of a solution to this?

I had a similar issue with wifi and it was ultimately resolved by SBFing back to stock, re-trying, and it worked like a charm. You can read the whole thread here: http://forum.xda-developers.com/moto...ocked-t2755730

While we never did figure out what the issue was (because my device was completely stock, other than flashing SuperSU/TWRP), but now it works great. I'm using the WiFi Tether for root users...download link is in the thread I linked above. I know its a bit of a pain to have to reinstall your apps, etc, but it was worth it to me.

Good Luck
28th July 2014, 05:22 PM   |  #3  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
help me att straight talk moto x WiFi and APN not working
I recently changed phones to a moto x att on straight talk my hot spot stopped working I'm really not technology savy I don't know what root means I just need my WiFi working again please help me I have not had good luck wit the whole switching phone thing my APN setting aren't right I can't receive MMS messages and now the hot spot not working

---------- Post added at 03:22 PM ---------- Previous post was at 02:46 PM ----------

I recently changed phones to a moto x att on straight talk my hot spot stopped working I'm really not technology savy I don't know what root means I just need my WiFi working again please help me I have not had good luck wit the whole switching phone thing my APN setting aren't right I can't receive MMS messages and now the hot spot not working
Post Reply Subscribe to Thread

Tags
tether, wifi
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes