Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,768,414 Members 49,822 Now Online
XDA Developers Android and Mobile Development Forum

I can NOT get ADB to recognize this phone in fastboot mode.

Tip us?
 
Nitemare15
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Nov 2009
Default I can NOT get ADB to recognize this phone in fastboot mode.

Please for the love of god help me. I've tried everything.

I have a developer edition. I have the newest drivers, the newest phone updates. Everything. It is recognized by ADB when I'm on the home screen, but when I am in fastboot mode itself it will not recognize the device. I can't unlock the BL because of this. It's VERY frustrating and I'm about 12 hours from selling this device and buying an HTC M8.

I have Windows 7 64 bit. I'm on the newest moto drivers, the newest FW for the X. I've uninstalled and re-installed and restarted my machine countless times. With no luck. With the drivers installed I booted the phone into fastboot mode, pulled up a command prompt where ADB was installed, ran adb devices and nothing. Over and over again. Please help me. I really want to keep this phone.
 
KJ
Old
#2  
KJ's Avatar
Recognized Contributor
Thanks Meter 3188
Posts: 7,695
Join Date: May 2011
Location: The boonies - southwest Ontario
Navigate to where fastboot.exe is installed, and run "fastboot devices".

And make sure phone is in bootloader mode.

Does it list serial number?
Sent from my new HTC One M8, N5, N7, Moto X, GTab3 or S2.

Need help with poor battery life on the N5...or any device really? Lots of info in first 4 posts! >>>>
[Battery Life Help] Troubleshoot Battery Issues Here....and Tips

 
dwhisent
Old
#3  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Dec 2010
I ran into the same issue last night, I just got a moto x DE for my wife, and a new laptop since last March when I unlocked my moto x DE. "adb devices" returned nothing, and I had a fresh install of the SDK and the moto drivers. Both old and new laptop on Win 7 64-bit. I googled trying to find a solution, but didn't find anything that worked. Grabbed my old laptop, hooked up to it, and it worked fine.

One suggestion I saw and didn't try was to remove/reload the moto drivers. Since I got it working and got her phone unlocked with my old laptop, I didn't pursue further.
 
KidJoe
Old
#4  
KidJoe's Avatar
Senior Member
Thanks Meter 738
Posts: 1,900
Join Date: Aug 2008
Location: Thorndale/Romansville, PA
Quote:
Originally Posted by Nitemare15 View Post
....With the drivers installed I booted the phone into fastboot mode, pulled up a command prompt where ADB was installed, ran adb devices and nothing. Over and over again. Please help me. I really want to keep this phone.
Adb devices wont work when the phone is in Booloader/fastboot mode.

Make sure you have the latest Moto drivers from here -> https://motorola-global-portal.custh...ail/a_id/88481

Follow this -> http://mark.cdmaforums.com/ADB.htm To install The Android SDK, PlatformTools, and mFastboot, and add platform tools to the Path.

once that is done.. type fasboot devices and see if you get anything. If no, look at Device Manager and make sure there are no ! or such in there.
aka Mark_Venture

My Moto X tips and info

Currently using Verizon Moto X Developer Edition on my personal line.. But I have too many devices to choose from for work and personal... For the full list click -> HERE <-

Sign up for Dropbox -> HERE
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes