[Q] I can't get my ATT Moto X recognized in ADB

121 posts
Thanks Meter: 7
By seabass950, Senior Member on 9th June 2014, 03:32 AM
-Running windows 8.1
-Installed latest motorola device manager
-tried several usb ports
-using minimal adb
-moto x set to usb debugging

any help?
9th June 2014, 11:55 AM |#2  
Flag Dorset, England
Thanks Meter: 3
Try installing PDANet -

The amount of times I've had driver problems (not just with Moto X) in the past, this thing always works. Once the driver's installed, you should just be able to uninstall the software, and the phone drivers should still be there.
The Following User Says Thank You to creebefu For This Useful Post: [ View ]
9th June 2014, 01:29 PM |#3  
KidJoe's Avatar
Recognized Contributor
Flag Thorndale/Romansville, PA
Thanks Meter: 1,559
If that doesn't work, follow this guide -> to install and configure ADB, and make sure you have the most up to date versions. Consider also installing the latest Google USB driver when doing so.

Also keep in mind, unfortunately there have been many with Windows 8/8.1 that have run into issues using ADB.

Please be sure to post back exactly what fixes/helps you so it can help others that might run into this issue.
The Following User Says Thank You to KidJoe For This Useful Post: [ View ]
9th June 2014, 06:40 PM |#4  
OP Senior Member
Thanks Meter: 7
Thanks all for the suggestions.

Looks like I fixed it by going in device manager and uninstalling the drivers. I uninstalled the ADB drivers (by showing hidden devices in device manager) and also the Motorola device.

Then I rebooted, and reinstalled motorola manager.
The Following User Says Thank You to seabass950 For This Useful Post: [ View ]

Guest Quick Reply (no urls or BBcode)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes