Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,151 Members 49,699 Now Online
XDA Developers Android and Mobile Development Forum

[Q] I can't get my ATT Moto X recognized in ADB

Tip us?
 
virtuewill
Old
#1  
Member - OP
Thanks Meter 3
Posts: 53
Join Date: Oct 2012
Default [Q] I can't get my ATT Moto X recognized in ADB

-Running windows 8.1
-Installed latest motorola device manager
-tried several usb ports
-using minimal adb
-moto x set to usb debugging

any help?
 
creebefu
Old
#2  
Member
Thanks Meter 3
Posts: 33
Join Date: Oct 2010
Location: Dorset, England
Try installing PDANet - http://pdanet.co/

The amount of times I've had driver problems (not just with Moto X) in the past, this thing always works. Once the driver's installed, you should just be able to uninstall the software, and the phone drivers should still be there.
The Following User Says Thank You to creebefu For This Useful Post: [ Click to Expand ]
 
KidJoe
Old
#3  
KidJoe's Avatar
Senior Member
Thanks Meter 667
Posts: 1,770
Join Date: Aug 2008
Location: Thorndale/Romansville, PA
If that doesn't work, follow this guide -> http://mark.cdmaforums.com/ADB.htm to install and configure ADB, and make sure you have the most up to date versions. Consider also installing the latest Google USB driver when doing so.

Also keep in mind, unfortunately there have been many with Windows 8/8.1 that have run into issues using ADB.

Please be sure to post back exactly what fixes/helps you so it can help others that might run into this issue.
aka Mark_Venture

My Moto X tips and info

Currently using Verizon Moto X Developer Edition on my personal line.. But I have too many devices to choose from for work and personal... For the full list click -> HERE <-

Sign up for Dropbox -> HERE
The Following User Says Thank You to KidJoe For This Useful Post: [ Click to Expand ]
 
virtuewill
Old
#4  
Member - OP
Thanks Meter 3
Posts: 53
Join Date: Oct 2012
Thanks all for the suggestions.

Looks like I fixed it by going in device manager and uninstalling the drivers. I uninstalled the ADB drivers (by showing hidden devices in device manager) and also the Motorola device.

Then I rebooted, and reinstalled motorola manager.
The Following User Says Thank You to virtuewill For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes