Post Reply

[Q] Black screen after trying to root, did i hard bricked my moto x?

OP monzillo

7th May 2014, 03:36 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2009
Hey guys,

So i was interested in installing a custom rom im my moto x and started by trying to root it.
Every thing was going fine, but after i placed the unlock code via CMD, i've got an error during the root process and my phone just died. Now all that i've got is a black screen, no matter if I try to hard reset or anything.

Any idea?



tl;dr my phone just died in the root process, wtf can i do?
7th May 2014, 07:53 AM   |  #2  
Senior Member
Thanks Meter: 100
 
553 posts
Join Date:Joined: Mar 2011
Unlock code? Root process?

Which model do you have? Which version of Android was it on? What exactly were you doing or using to root or unlock?
7th May 2014, 10:48 AM   |  #3  
DANIEL AMBRUSO's Avatar
Senior Member
Thanks Meter: 12
 
161 posts
Join Date:Joined: Apr 2014
More
Which model you have used ?
7th May 2014, 01:27 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2009
I have a x1058, it was on android 4.4.2 and was using a tutorial from a brazilian guy, wich involved downloading adb and fastboot scripts and run them trough cmd.
8th May 2014, 02:01 AM   |  #5  
KJ's Avatar
XDA: ASSIST
Recognized Contributor
Flag The boonies - southwest Ontario
Thanks Meter: 4,159
 
10,387 posts
Join Date:Joined: May 2011
More
You will need to be far more specific in what commands you did, if any...and the specific errors.

Only way we'll know what's happened.
8th May 2014, 10:56 AM   |  #6  
LukeNukem's Avatar
Senior Member
Thanks Meter: 29
 
131 posts
Join Date:Joined: Jun 2012
More
It may be of some help if you post the tutorial you followed and say exactly at what step things went wrong.

Sent from my Moto X using Tapatalk Pro
8th May 2014, 11:49 AM   |  #7  
KidJoe's Avatar
Senior Member
Flag Thorndale/Romansville, PA
Thanks Meter: 848
 
2,087 posts
Join Date:Joined: Aug 2008
More
Quote:
Originally Posted by monzillo

I have a x1058, it was on android 4.4.2 and was using a tutorial from a brazilian guy, wich involved downloading adb and fastboot scripts and run them trough cmd.

The XT1058 has a locked bootloader, so I hope that tutorial didn't have you try to downgrade your ROM in order to use SlapMyMoto/MotoWpNoMo to root and disable write protection.

SlapMyMoto/RockMyMoto/etc, used on 4.4 and lower, involved downgrading the rom to use an exploit in 4.2.2 to gain root. But with 4.4.2 you can't downgrade the rom safely, without risk of bricking your phone anymore. Additionally, 4.4.2 closed the exploits used by SlapMyMoto/RockMyMoto to gain root, and the exploit used by MotoWpNoMo to disable write protection.

As others have suggested, post a link to the turtorial, and any error messages you saw while running the scripts.

Also, try booting into bootloader/fastboot mode. Can you get there? What version bootloader does it say you are on? I believe 30.B4 is 4.4.2 and 30.71 is 4.4 and 4.2.2 w/camera fix. If you have 30.B4, then your only fix might be using RSDLite to flash the 4.4.2 SBF for your carrier, or mFastboot to individually flash all parts of 4.4.2 on your phone, and then forget about rooting unless Moto's web site gives out the bootloader unlock code for your phone.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank