WhatsApp Decides to Protect Your Data

When Facebook bought WhatsApp for the absurdly large sum of $19b back in February, they took the tech … more

Bring Back LTE on the Google Nexus 4 Running Lollipop

One of the predecessors of the latest, largest, and greatest Gooogle Nexus 6(theGoogle … more

Google Maps, My Maps, YouTube, Androidify, Slides, Music Updated–Here’s What’s New

In the last few weeks, Google has been … more

SuperSU BETA: Root Android Lollipop on Stock Kernel

Up until now, if you wanted to get root on Android 5.0, you needed to flash a modified … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Bluetooth Volume Control Issues

OP jaredtritsch

4th March 2014, 07:01 PM   |  #1  
jaredtritsch's Avatar
OP Junior Member
Flag Salt Lake City, UT
Thanks Meter: 4
 
16 posts
Join Date:Joined: Feb 2014
More
I have noticed recently that when I am connected to a Bluetooth speaker (I have seen this with my Jawbone Big JamBox, my Sony DT1300 Home Theater Amp, and my JayBird BlueBuds X) that the volume controls go completely crazy.

If I press volume down, on either the device or the phone (unified volume control) the volume goes down like normal.

If I press volume up, on either the device or the phone (unified volume control) the volume ALSO goes down. Watching the volume display on he phone as it happens reveals the volume slider stepping up one level, then slipping back down to a position slightly lower than it was initially. Repeated presses of volume up drive the volume down further to the point where sound becomes muted.

Since this is happening with three COMPLETELY different bluetooth devices (A desktop speaker, a headset, and a Home Theater System) and this is NOT happening when I connect using my Samsung Galaxy Tab Pro 10.1, I can only assume something on the Moto X is to blame.

Any ideas?
Last edited by jaredtritsch; 4th March 2014 at 07:07 PM. Reason: Spellcheck. Lawl.
4th March 2014, 07:29 PM   |  #2  
Solutions Etcetera's Avatar
Senior Member
Flag Sierra Nevada (west slope)
Thanks Meter: 163
 
843 posts
Join Date:Joined: Oct 2012
More
What version of Android on your tab?
4th March 2014, 09:18 PM   |  #3  
jaredtritsch's Avatar
OP Junior Member
Flag Salt Lake City, UT
Thanks Meter: 4
 
16 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by Solutions Etcetera

What version of Android on your tab?

4.4.2 Unrooted on Tab
4.4.0 Rooted on Moto X
4th March 2014, 11:18 PM   |  #4  
Solutions Etcetera's Avatar
Senior Member
Flag Sierra Nevada (west slope)
Thanks Meter: 163
 
843 posts
Join Date:Joined: Oct 2012
More
Quote:
Originally Posted by jaredtritsch

4.4.2 Unrooted on Tab
4.4.0 Rooted on Moto X

This issue was introduced in 4.4 (an Android issue), and affected both my Moto X and my Nexus 4. 4.4.2 fixed it on the Nexus 4, but it seems a reasonable assumption that the Moto X is not using the exact same BT stack as the Nexus in 4.4.2. Frustrating!

Gotta love Android!
1st May 2014, 04:26 AM   |  #5  
Senior Member
Thanks Meter: 42
 
156 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by jaredtritsch

If I press volume up, on either the device or the phone (unified volume control) the volume ALSO goes down. Watching the volume display on he phone as it happens reveals the volume slider stepping up one level, then slipping back down to a position slightly lower than it was initially. Repeated presses of volume up drive the volume down further to the point where sound becomes muted.

Did you ever make any progress on figuring this out? I also have the Big Jambox and saw the crazy volume behavior, but dismissed it. Then, I got the Kinivo BTC450 and got something even weirder!!!

Starting from lowest bluetooth volume to highest (using buttons on the phone):

can't hear -> can't hear -> can almost hear -> almost there -> can't hear -> can almost hear -> almost there -> too loud -> too loud

The slider behaves normally, not jumping down when it should be going up; but the volume is all over the place. This behavior is present when pushing the volume up or down, unlike the Jambox issue on volume up. I haven't reached out to Motorola on this.
1st May 2014, 05:10 AM   |  #6  
Senior Member
Thanks Meter: 524
 
2,583 posts
Join Date:Joined: Sep 2012
Persist+ works for me but I do not have all the gizmos
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes