Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,770,879 Members 43,738 Now Online
XDA Developers Android and Mobile Development Forum

Bluetooth pairing problem with car

Tip us?
 
ghstudio
Old
#1  
Member - OP
Thanks Meter 7
Posts: 61
Join Date: Dec 2013
Default Bluetooth pairing problem with car

My moto-x Verizon DE with 4.2.2 installed connects to my Mercedes fine and the phonebook is loaded. Then, at random times, it disconnects and reconnects. This can be during a call. I have no clue what is making it drop. This has happened since I received the phone with 4.0 and it's getting frustrating.

I would love a solution....
 
Kenichi
Old
#2  
Kenichi's Avatar
Senior Member
Thanks Meter 21
Posts: 201
Join Date: Jan 2010
Quote:
Originally Posted by ghstudio View Post
My moto-x Verizon DE with 4.2.2 installed connects to my Mercedes fine and the phonebook is loaded. Then, at random times, it disconnects and reconnects. This can be during a call. I have no clue what is making it drop. This has happened since I received the phone with 4.0 and it's getting frustrating.

I would love a solution....
4.2.2? Or 4.4.2? If you haven't upgraded yet, you are missing out on a world of goodness.

If you are 4.4.2, I have no clue why you have issues, as 4.4+ cleared all my issues with Bluetooth. Good luck!

Kenichi
 
mechanical tool
Old
#3  
Member
Thanks Meter 10
Posts: 80
Join Date: Jan 2011
I have had mine disconnect once or twice when i had a lot of apps running.


Sent from my XT1058 using xda app-developers app
 
ghstudio
Old
#4  
Member - OP
Thanks Meter 7
Posts: 61
Join Date: Dec 2013
Quote:
Originally Posted by Kenichi View Post
4.2.2? Or 4.4.2? If you haven't upgraded yet, you are missing out on a world of goodness.

If you are 4.4.2, I have no clue why you have issues, as 4.4+ cleared all my issues with Bluetooth. Good luck!

Kenichi
fingers typed the wrong version. I do have 4.4.2 running.

It may be some interaction between programs...for example, I wear a pebble watch (bluetooth) and a host of other programs that probably do on-line updates during the day. If it's interaction, it's going to be hard to find the culprit.....
 
JoeSchmoe007
Old
#5  
Senior Member
Thanks Meter 8
Posts: 120
Join Date: Mar 2011
Quote:
Originally Posted by ghstudio View Post
fingers typed the wrong version. I do have 4.4.2 running.

It may be some interaction between programs...for example, I wear a pebble watch (bluetooth) and a host of other programs that probably do on-line updates during the day. If it's interaction, it's going to be hard to find the culprit.....
A lot of people reported BT issues with car systems after 4.4 and 4.4.2 upgrades not only on Moto X but also on other phones. Apparently something was changed in BT implementation in these versions. I am on 4.2.2, it is perfectly compatible with my car, so I am never upgrading because downgrade from 4.4.2 back to 4.2.2 is not possible for Moto X.
 
fury683
Old
#6  
Senior Member
Thanks Meter 60
Posts: 244
Join Date: Dec 2010

 
DONATE TO ME
Mine does the same thing in my Chevy Cobalt. I see it flashing "Bluetooth connected" on my radio screen periodically when I'm driving. Sometimes if I get a phone call it won't be connected right away, so I have to answer the phone with the handset, and after a few seconds Bluetooth picks up.

It also doesn't auto connect to a A2DP bluetooth adapter that I have in my car for streaming music. I have to either connect manually, or use an app to connect once it connects to my car radio deck.

I'm rooted on 4.4. Just bought an unlock code, and will be bumping up to 4.4.2, hoping that makes it a little more reliable...
furyť™ - not helping the situation since 1987
Enable Moto X LED Charging Indicator (without Tasker)
Current: VZW MM Moto X, Woven Black, Black, Black; Nexus 7 (2013) | Previous: Droid Razr Maxx; Droid X; Nook Color (running CM)
 
Kenichi
Old
#7  
Kenichi's Avatar
Senior Member
Thanks Meter 21
Posts: 201
Join Date: Jan 2010
Quote:
Originally Posted by JoeSchmoe007 View Post
A lot of people reported BT issues with car systems after 4.4 and 4.4.2 upgrades not only on Moto X but also on other phones. Apparently something was changed in BT implementation in these versions. I am on 4.2.2, it is perfectly compatible with my car, so I am never upgrading because downgrade from 4.4.2 back to 4.2.2 is not possible for Moto X.
If you move to 4.4 it'll be fine. 4.4.2 will change your bootloader however.

Kenichi
 
ghstudio
Old
#8  
Member - OP
Thanks Meter 7
Posts: 61
Join Date: Dec 2013
Quote:
Originally Posted by Kenichi View Post
If you move to 4.4 it'll be fine. 4.4.2 will change your bootloader however.

Kenichi
4.4.2 does NOT solve the problem
The Following User Says Thank You to ghstudio For This Useful Post: [ Click to Expand ]
 
uToTMeH8
Old
#9  
uToTMeH8's Avatar
Senior Member
Thanks Meter 114
Posts: 349
Join Date: Dec 2011
Location: MA
The Bluetooth stack was changed in 4.4 making it unreliable. I had to downgrade to 4.2.2 because I rely on Bluetooth. On 4.4 the switch off between voice calls and music rarely ever works and you have to toggle Bluetooth off and on to get it working again.

Sent from my XT1058 using Tapatalk
 
tu3218
Old
#10  
Senior Member
Thanks Meter 252
Posts: 2,454
Join Date: Apr 2009
Completely stock here with 4.4.2 and my bluetooth works perfect in my 13 Elantra. No issues at all with disconnecting.

Tags
bluetooth car dropout
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes