Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Connecting Moto X to Computer Issue

OP Bionic22

23rd August 2014, 01:07 AM   |  #1  
Bionic22's Avatar
OP Senior Member
Thanks Meter: 28
 
124 posts
Join Date:Joined: Jun 2013
More
So, every time I connect my Moto X to my Windows Laptop via USB, it always keeps plugging and unplugging itself as if I was doing it. The phone icon appears and it begins to try and load the memory storage and then it just vanishes and "unplugs itself". As of now, I just unplug the USB cable from one slot of the laptop and then insert it in another, and it fixes the issue.

Now, that doesn't work either. What's the problem and how can I fix it?
23rd August 2014, 01:17 AM   |  #2  
Darth's Avatar
XDA: ASSIST
Recognized Contributor
Flag The boonies - southwest Ontario
Thanks Meter: 4,878
 
13,411 posts
Join Date:Joined: May 2011
More
Chances are it's one of a few things.

Bad cable. Bad ports on laptop. Or the port on your phone.

I'd start with some different cables.

Then try a different pc.

If it's the phone, then that's a problem. The phone ports are fragile. My daughters Gtab3 has a wonky port, cause I'm sure the plastic tab was snapped by her using the tablet while it's plugged in. So now to charge it, it will only work sitting still on whatever and I have to jiggle the cable to get it just right. It's only help by the wires inside now.
The Following User Says Thank You to Darth For This Useful Post: [ View ]
23rd August 2014, 01:41 AM   |  #3  
Bionic22's Avatar
OP Senior Member
Thanks Meter: 28
 
124 posts
Join Date:Joined: Jun 2013
More
Quote:
Originally Posted by KJ

Chances are it's one of a few things.

Bad cable. Bad ports on laptop. Or the port on your phone.

I'd start with some different cables.

Then try a different pc.

If it's the phone, then that's a problem. The phone ports are fragile. My daughters Gtab3 has a wonky port, cause I'm sure the plastic tab was snapped by her using the tablet while it's plugged in. So now to charge it, it will only work sitting still on whatever and I have to jiggle the cable to get it just right. It's only help by the wires inside now.

I repaired the Moto X Device Manager and now I'm using a different cable. So far. so good. I'll report back in a few days to see if anything changes.
The Following User Says Thank You to Bionic22 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
computer, connection, moto x, problem, usb
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes