Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,353 Members 40,112 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Connecting Moto X to Computer Issue

Tip us?
 
Bionic22
Old
#1  
Bionic22's Avatar
Senior Member - OP
Thanks Meter 28
Posts: 116
Join Date: Jun 2013
Question [Q] Connecting Moto X to Computer Issue

So, every time I connect my Moto X to my Windows Laptop via USB, it always keeps plugging and unplugging itself as if I was doing it. The phone icon appears and it begins to try and load the memory storage and then it just vanishes and "unplugs itself". As of now, I just unplug the USB cable from one slot of the laptop and then insert it in another, and it fixes the issue.

Now, that doesn't work either. What's the problem and how can I fix it?
 
KJ
Old
#2  
KJ's Avatar
Recognized Contributor
Thanks Meter 3,513
Posts: 8,442
Join Date: May 2011
Location: The boonies - southwest Ontario
Chances are it's one of a few things.

Bad cable. Bad ports on laptop. Or the port on your phone.

I'd start with some different cables.

Then try a different pc.

If it's the phone, then that's a problem. The phone ports are fragile. My daughters Gtab3 has a wonky port, cause I'm sure the plastic tab was snapped by her using the tablet while it's plugged in. So now to charge it, it will only work sitting still on whatever and I have to jiggle the cable to get it just right. It's only help by the wires inside now.
Sent from my new HTC One M8, N7, Moto X, GTab3 or S2.

Need help with poor battery life? Any device welcome, even tho its an N5 thread. Please specify if on a device other than N5. Lots of info in first 4 posts! >>>>
[Battery Life Help] Troubleshoot Battery Issues Here....and Tips

The Following User Says Thank You to KJ For This Useful Post: [ Click to Expand ]
 
Bionic22
Old
#3  
Bionic22's Avatar
Senior Member - OP
Thanks Meter 28
Posts: 116
Join Date: Jun 2013
Quote:
Originally Posted by KJ View Post
Chances are it's one of a few things.

Bad cable. Bad ports on laptop. Or the port on your phone.

I'd start with some different cables.

Then try a different pc.

If it's the phone, then that's a problem. The phone ports are fragile. My daughters Gtab3 has a wonky port, cause I'm sure the plastic tab was snapped by her using the tablet while it's plugged in. So now to charge it, it will only work sitting still on whatever and I have to jiggle the cable to get it just right. It's only help by the wires inside now.
I repaired the Moto X Device Manager and now I'm using a different cable. So far. so good. I'll report back in a few days to see if anything changes.
The Following User Says Thank You to Bionic22 For This Useful Post: [ Click to Expand ]
Tags
computer, connection, moto x, problem, usb
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes