Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Unknown App Flashing When Toggling Wifi

OP fury683

6th March 2014, 03:50 PM   |  #1  
OP Senior Member
Thanks Meter: 95
 
419 posts
Join Date:Joined: Dec 2010
Donate to Me
More
Last night I was at home and noticed my wifi wasn't on, so I used the quick settings in the shade to toggle it. After a few seconds, wifi connected, and some unknown app took focus and closed repeatedly. After a few moments, it stopped and all was well.

I thought it was strange, so I turned wifi back off and the same thing happened. I rebooted, tried again, and got the same result. I was trying to think of a way to see what was happening, so I tried using the Screen Record function in Gravity Box, which didn't help much, because it happens so fast, and no info is displayed, just a black window that goes away quickly.

I then turned on the CPU usage in Developer Options to see if anything consistently came to the top when toggling. I saw a few apps each time Plume (Twitter), and Maildroid (email) were two of them. Both of these apps behave differently on wifi and 3G/4G (push vs. pull), so thought -maybe- it could be something with that. I uninstalled both of those, rebooted and tried again, getting the same result.

I recorded the screen when this was happening with the CPU usage displayed, and was wondering if anyone has any ideas? I don't really want to uninstall and reinstall EVERY app on my phone, so I was hoping someone may have seen this before or see something I'm missing when watching it happen.

Video: https://copy.com/8L6VTsqcdbUjVTz

Thanks for any input anyone can offer!
6th March 2014, 03:59 PM   |  #2  
sumonmolla's Avatar
Member
Thanks Meter: 5
 
85 posts
Join Date:Joined: Feb 2014
Do you check virus from your phone ?
18th March 2014, 02:54 PM   |  #3  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2011
Exclamation
I am also having this, seems to be due to 4.4.2 OTA, which I continue to delay as I am rooted.

Mine doens't only happen with wifi change, but also just randomly when using hangouts, keyboard stays out but hangouts min -> maxes quickly. I have tried freezing the update apps but it apparently didn't do anything as I was still asked to update earlier.
18th March 2014, 03:22 PM   |  #4  
OP Senior Member
Thanks Meter: 95
 
419 posts
Join Date:Joined: Dec 2010
Donate to Me
More
Only hangouts? I have that app disabled.in the app settings.
19th March 2014, 08:46 PM   |  #5  
OP Senior Member
Thanks Meter: 95
 
419 posts
Join Date:Joined: Dec 2010
Donate to Me
More
I can't say for sure that being on 4.4.2 fixed it, but I am on 4.4.2 now and it is not happening anymore.

I unlocked my bootloader and did the 4.4.2 SBF, unlocked and rooted. I installed probably 99% of the same apps (only ditched 1-2 that I never used anymore) and I am not having the flashing issue anymore.

Hard to tell for certain if the pending OTA was the cause, but it may have been.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes