How to Disable Data Encryption on Nexus 6

In late September, Google decided to step on NSA’s toes and turn on encryption by default in … more

DJI Phantom 2 Vision+ Review – XDA TV

The holidays will be here in no time, so why not start thinking about gifts now? Youll be ahead … more

Mozilla Ditches Google, Makes Yahoo Default Search Engine

Mozilla and Google have had a long-standing relationship of about 10 years. Google … more

Learn More About Linux with Linux Man Pages

Linux is quite a powerful and very configurable operating system. Thanks to some user-friendly … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Disable bluetooth MAP?

OP triton302

2nd November 2014, 10:58 AM   |  #11  
Senior Member
Thanks Meter: 24
 
153 posts
Join Date:Joined: Jul 2013
More
Quote:
Originally Posted by dtg7

well without putting in commands manually I see two things you guys can try. the first doesn't need root while the second one does.

1) turn on Bluetooth on your phones, then go to Settings -> Apps -> Running -> Bluetooth Share then just Stop the Map service. This method will stick as long as you don't turn off Bluetooth and start it again, and as long as you don't restart the phone. if you do either you'll have to do the stopping again.

2) this requires that your phone be rooted, but on the plus side it might be more permanent. There's a nifty app in the play store made by some benevolent developer that claims to disable any service started by any app. appropriately enough the app is called Disable Service. You open the app, slide over to the System Apps section, find Bluetooth Share and click it, then just uncheck the Maps service box. So simple, but won't work without root. Try it with Bluetooth off and if that doesn't work reset it then try it with Bluetooth on. But word of caution you don't want to go messing around disabling other things unless you're sure of what you're doing. disabling the wrong thing will cause you problems.

good luck.

Thanks so much! Option 2 is exactly what I've been looking for! Option 1 doesn't work for me because I use Trigger and have conditional BT on/off and that would just recreate the same problem lol.
3rd November 2014, 03:00 AM   |  #12  
triton302's Avatar
OP Senior Member
Flag NoVA
Thanks Meter: 46
 
562 posts
Join Date:Joined: Feb 2010
More
Just tried option 2... If any of those services are unchecked, Bluetooth itself turns off automatically and won't turn back on until that service is restored.
4th November 2014, 09:27 AM   |  #13  
Senior Member
Thanks Meter: 24
 
153 posts
Join Date:Joined: Jul 2013
More
Quote:
Originally Posted by triton302

Just tried option 2... If any of those services are unchecked, Bluetooth itself turns off automatically and won't turn back on until that service is restored.

Yep same here, tried it on my way home yesterday and the disable service app completely disables bluetooth if you disable MAP.
4th November 2014, 05:52 PM   |  #14  
Member
Thanks Meter: 33
 
82 posts
Join Date:Joined: Feb 2013
Quote:
Originally Posted by boosting1bar

Yep same here, tried it on my way home yesterday and the disable service app completely disables bluetooth if you disable MAP.

Wow no breaks...but not quite out of ideas yet. a few more to spitball, going from simple to more complex:

a) we've established there's no option to disable MAP from within SYNC under System Settings. What about under Phone Settings? Indications are there should be an option there to turn off Message Notification. If it's there set it to OFF. frankly I'd expect there to be such a setting somewhere in there.

b) reaching a bit here, but in Disable Service app I notice there's another system app that has Bluetooth service settings. the app's name is org.codeaurora.bluetooth (Apparently Code Aurora is the Qualcomm Linux kernel). No idea if this will work where the other failed but won't hurt to try. the service says BluetoothMasService but if you check the full name it is map (maybe service instead of profile).

c) this one brings out the big guns. not only do you need root, but you also need Xposed installed. if you already have Xposed then it would be quick to try. if not, just read up on it. anyway, with Xposed installed you need the AppOpsXposed module. when you have that up and running you open the App Ops screen of the Bluetooth Share app (a few ways to do that, doesn't matter how). in that screen you turn off all of Bluetooth Share's access to SMS. Basically you disable Bluetooth from interacting with Messaging. you revoke the permissions. Bluetooth will still work unaware that it can't access messages, and I figure if it can't access messages it damn well can't send them to the car.
There's another module that can do this more thoroughly, but App Ops is less scary/more user friendly.

that's it. personally I still prefer my original idea of figuring out how to do it manually thru setprop and build.prop, but if that's not an option then try these.
Last edited by dtg7; 4th November 2014 at 07:13 PM.
The Following 2 Users Say Thank You to dtg7 For This Useful Post: [ View ]
4th November 2014, 06:32 PM   |  #15  
triton302's Avatar
OP Senior Member
Flag NoVA
Thanks Meter: 46
 
562 posts
Join Date:Joined: Feb 2010
More
Roger, I'm off work today so I'll try these out here shortly.

EDIT: From what I recall, if you have a recent version of MFT, there are no options whatsoever for MAP, in phone or system settings. I'll double check.

EDITING EDIT: #2 doesn't work.
Last edited by triton302; 4th November 2014 at 07:15 PM.
4th November 2014, 07:14 PM   |  #16  
triton302's Avatar
OP Senior Member
Flag NoVA
Thanks Meter: 46
 
562 posts
Join Date:Joined: Feb 2010
More
Quote:
Originally Posted by dtg7

Wow no breaks...but not quite out of ideas yet. a few more to spitball, going from simple to more complex:

a) we've established there's no option to disable MAP from within SYNC under System Settings. What about under Phone Settings? Indications are there should be an option there to turn off Message Notification. If it's there set it to OFF. frankly I'd expect there to be such a setting somewhere in there.

b) reaching a bit here, but in Disable Service app I notice there's another system app that has Bluetooth service settings. the app's name is org.codeaurora.bluetooth (Apparently Code Aurora is the Qualcomm Linux kernel). No idea if this will work where the other failed but won't hurt to try. the service says BluetoothMasService but if you check the full name it is map (maybe service instead of protocol).

c) this one brings out the big guns. not only do you need root, but you also need Xposed installed. if you already have Xposed then it would be quick to try. if not, just read up on it. anyway, with Xposed installed you need the AppOpsXposed module. when you have that up and running you open the App Ops screen of the Bluetooth Share app (a few ways to do that, doesn't matter how). in that screen you turn off all of Bluetooth Share's access to SMS. Basically you disable Bluetooth from interacting with Messaging. you revoke the permissions. Bluetooth will still work unaware that it can't access messages, and I figure if it can't access messages it damn well can't send them to the car.
There's another module that can do this more thoroughly, but App Ops is less scary/more user friendly.

that's it. personally I still prefer my original idea of figuring out how to do it manually thru setprop and build.prop, but if that's not an option then try these.

I think we have a winner! #3 works perfectly.

I tested it with the phone unlocked and locked, rebooting the phone, toggling bluetooth on and off, turning the car on and off... seems to work every time. As long as you turn off just the SMS/MMS options, you can still have it send and receive calls and allow the device to remain unlocked while connected.
4th November 2014, 07:33 PM   |  #17  
Member
Thanks Meter: 33
 
82 posts
Join Date:Joined: Feb 2013
Ahhhh...... Success feels good...

Xposed is pretty amazing... It gives us a fighting chance lol.
if only they'd installed Xposed on Skynet things might have turned out differently...
5th November 2014, 03:33 PM   |  #18  
Senior Member
Thanks Meter: 24
 
153 posts
Join Date:Joined: Jul 2013
More
Quote:
Originally Posted by dtg7

c) this one brings out the big guns. not only do you need root, but you also need Xposed installed. if you already have Xposed then it would be quick to try. if not, just read up on it. anyway, with Xposed installed you need the AppOpsXposed module. when you have that up and running you open the App Ops screen of the Bluetooth Share app (a few ways to do that, doesn't matter how). in that screen you turn off all of Bluetooth Share's access to SMS. Basically you disable Bluetooth from interacting with Messaging. you revoke the permissions. Bluetooth will still work unaware that it can't access messages, and I figure if it can't access messages it damn well can't send them to the car.
There's another module that can do this more thoroughly, but App Ops is less scary/more user friendly.

Awesome, worked here as well!! I'd looked through xposed and didn't see any modules that would do what we were after, completely forgot about AppOps. Outstanding work and thanks so much for the help!
5th November 2014, 04:58 PM   |  #19  
Member
Thanks Meter: 33
 
82 posts
Join Date:Joined: Feb 2013
You're welcome!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes