FORUMS
Remove All Ads from XDA

ATT Moto X slow LTE speeds?

376 posts
Thanks Meter: 62
 
By glenroebuck, Senior Member on 17th March 2014, 12:29 AM
Post Reply Subscribe to Thread Email Thread
Hi I have an ATT Moto X we just got updated to 4.4 from att - Our other phone is an LG Optimus Pro - both are att branded. The LOGP consistently gets much better LTE speeds than the Moto X? Sitting at home, my LOGP gets 16.9 Mbps down and 9.6 Mbps up where as the Moto X is getting 9 down and 4 up?? Literally right next to each other. ???? any ideas?
The Following User Says Thank You to glenroebuck For This Useful Post: [ View ] Gift glenroebuck Ad-Free
 
 
19th March 2014, 03:27 AM |#2  
drago10029's Avatar
Senior Member
Flag Phazon Mines
Thanks Meter: 126
 
More
Quote:
Originally Posted by glenroebuck

Hi I have an ATT Moto X we just got updated to 4.4 from att - Our other phone is an LG Optimus Pro - both are att branded. The LOGP consistently gets much better LTE speeds than the Moto X? Sitting at home, my LOGP gets 16.9 Mbps down and 9.6 Mbps up where as the Moto X is getting 9 down and 4 up?? Literally right next to each other. ???? any ideas?

could depend on a lot of things. the apps you have installed, if you're rooted or running custom ROM, different radio. has it only been happening since the update?

Also what have you tried to do to fix it? i can make a whole big list but you should always say what you tried first.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes