WhatsApp Decides to Protect Your Data

When Facebook bought WhatsApp for the absurdly large sum of $19b back in February, they took the tech … more

Bring Back LTE on the Google Nexus 4 Running Lollipop

One of the predecessors of the latest, largest, and greatest Gooogle Nexus 6(theGoogle … more

Google Maps, My Maps, YouTube, Androidify, Slides, Music Updated–Here’s What’s New

In the last few weeks, Google has been … more

SuperSU BETA: Root Android Lollipop on Stock Kernel

Up until now, if you wanted to get root on Android 5.0, you needed to flash a modified … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Not getting MMS/data - APN issue?

OP add lightness

17th May 2014, 06:27 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2014
Hi everyone, I have an AT&T Moto X that hasn't been able to send or receive multimedia messages, and the data connection doesn't work. From what I've read, I believe it's an APN issue. However, I'm hesitant to mess with the settings because it's still on a basic phone plan, with no data. When I upgraded to the X, AT&T never automatically added a data plan. If possible, I really want to keep it this way, as I have no need for data, but would like to get MMS working.

In this thread (http://forum.xda-developers.com/show....php?t=2238660) post #4 says to leave APN Type set to "phone" if you don't have an LTE plan. Is this a way to make MMS work, but not data? Is there a way to do this at all? And can that be done without AT&T recognizing the smartphone and adding a data plan? Any replies are appreciated

Here's my APN settings, defaults that came with the phone:


Name: AT&T phone
APN: phone
Proxy: not set
Port: not set
username: not set
password: not set
server: not set
mmsc: not set
mms proxy: not set
mms port: not set
mcc: 310
mnc: 410
Authentication type: not set
apn type: default,supl,hipri,dun
apn protocol: ipv4
apn roaming protocol: ipv4
apn enable/disable: enabled
bearer: unspecified
mvno type: not set
mvno value: not set

Name: ATT US MMS
APN: phone
Proxy: not set
Port: not set
username: not set
password: not set
server: not set
mmsc: http://mmsc.mobile.att.net
mms proxy: proxy.mobile.att.net
mms port: 80
mcc: 310
mnc: 410
Authentication type: not set
apn type: mms
apn protocol: ipv4
apn roaming protocol: ipv4
apn enable/disable: enabled
bearer: unspecified
mvno type: not set
mvno value: not set
18th May 2014, 05:00 PM   |  #2  
ai6908's Avatar
Senior Member
Flag Land of Lincoln
Thanks Meter: 267
 
3,609 posts
Join Date:Joined: Nov 2006
Donate to Me
More
You need some sort of data to download multimedia. Does it work with Wifi?
18th May 2014, 11:06 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by ai6908

You need some sort of data to download multimedia. Does it work with Wifi?

You mean a data connection, not plan, right? It doesn't work over wifi. From what I've read, only Sprint allows downloading MMS over wifi, not AT&T.
22nd May 2014, 09:29 PM   |  #4  
kzoodroid's Avatar
Senior Member
Flag Kalamazoo
Thanks Meter: 266
 
1,350 posts
Join Date:Joined: Jun 2010
More
I have the same problem, data just all of a sudden quit working and I had an LTE connection with no problems since I got the phone in November, same APN's as you on my phone and both always worked. I now get nothing no 2G, 3G, HSPA+ or LTE. SMS and calls still work but no MMS as expected since it requires a data connection. Spent 2 hours with AT&T both online and in store trying to see if it was anything on their end. Tried every APN they could find for the MotoX, about 4 or 5 different ones they came up with, even tried a new SIM card and still nothing. I did a factory reset last night in desperation and still no data so I finally RMA'd the phone with Motorolla tech support and the new (refurbished) one should arrive tomorrow. We'll see if that fixes it.
Last edited by kzoodroid; 22nd May 2014 at 09:34 PM.
3rd June 2014, 04:51 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2014
You had to send it back? Oh wow. Please post an update when you get your new phone or get it figured out. Thanks for the response!!
3rd June 2014, 05:00 AM   |  #6  
samwathegreat's Avatar
Senior Member
Thanks Meter: 1,774
 
2,025 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by add lightness

Hi everyone, I have an AT&T Moto X that hasn't been able to send or receive multimedia messages, and the data connection doesn't work. From what I've read, I believe it's an APN issue. However, I'm hesitant to mess with the settings because it's still on a basic phone plan, with no data. When I upgraded to the X, AT&T never automatically added a data plan. If possible, I really want to keep it this way, as I have no need for data, but would like to get MMS working.

In this thread (http://forum.xda-developers.com/show....php?t=2238660) post #4 says to leave APN Type set to "phone" if you don't have an LTE plan. Is this a way to make MMS work, but not data? Is there a way to do this at all? And can that be done without AT&T recognizing the smartphone and adding a data plan? Any replies are appreciated

Here's my APN settings, defaults that came with the phone:


Name: AT&T phone
APN: phone
Proxy: not set
Port: not set
username: not set
password: not set
server: not set
mmsc: not set
mms proxy: not set
mms port: not set
mcc: 310
mnc: 410
Authentication type: not set
apn type: default,supl,hipri,dun
apn protocol: ipv4
apn roaming protocol: ipv4
apn enable/disable: enabled
bearer: unspecified
mvno type: not set
mvno value: not set

Name: ATT US MMS
APN: phone
Proxy: not set
Port: not set
username: not set
password: not set
server: not set
mmsc: http://mmsc.mobile.att.net
mms proxy: proxy.mobile.att.net
mms port: 80
mcc: 310
mnc: 410
Authentication type: not set
apn type: mms
apn protocol: ipv4
apn roaming protocol: ipv4
apn enable/disable: enabled
bearer: unspecified
mvno type: not set
mvno value: not set

Not sure if this is the issue, but AT&T's own site says that the MMSC url should be: http://mmsc.cingular.com

You may give that a shot.

Additionally, from what I understand, MMS is ONLY transmitted through either EDGE, HSPA, HSPA+, or LTE

If you don't have data at all, I'm not sure if you can even send or receive MMS.


Good Luck
26th August 2014, 07:43 PM   |  #7  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2014
Time for a very late update, in case anyone else has this issue. I did finally get my data working, using the 3G APN settings on this page: (first result when you google "att apn settings", I can't post links yet)

Now, I mentioned in my first post that I really only wanted mms, so what I did was make two new APNs - one a copy of my original, non-working APN, but with APN type changed to only "default", and I selected this one. The second APN is the settings from the link above, but with APN type changed to only "mms". So now when I have data turned on, only mms works, not any other mobile data. AT&T still hasn't recognized the smartphone on the account and thus hasn't forced me to add a data plan.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes