5,601,223 Members 58,188 Now Online
XDA Developers Android and Mobile Development Forum

Help with changing carriers

Tip us?
 
lanman1
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2011
Default Help with changing carriers

I bought a used XT1053 that was on Nextel Mexico and intend to use it with Straighttalk so I unlocked the bootloader so I can run the TMO 4.4 firmware. The upgrade went fine except after I reboot once, the second time the unit comes up, the boot animation changes and it displays a verizon splash screen. I flashed TMO_RETAIL_XT1053_4.4-13.11.1Q2.X-69-3_MR2_1FF that I downloaded straight from Moto and ran the .bat in fastboot. Any ideas what is going on? All seems to work on the phone and I have 4G/LTE.
 
Steve-x
Old
#2  
Senior Member
Thanks Meter 163
Posts: 532
Join Date: Sep 2013
Location: Langley, BC
Quote:
Originally Posted by lanman1 View Post
I bought a used XT1053 that was on Nextel Mexico and intend to use it with Straighttalk so I unlocked the bootloader so I can run the TMO 4.4 firmware. The upgrade went fine except after I reboot once, the second time the unit comes up, the boot animation changes and it displays a verizon splash screen. I flashed TMO_RETAIL_XT1053_4.4-13.11.1Q2.X-69-3_MR2_1FF that I downloaded straight from Moto and ran the .bat in fastboot. Any ideas what is going on? All seems to work on the phone and I have 4G/LTE.
Sounds like you downloaded the Verizon Dev edition firmware and not the tmobile, I'd download it again.
 
lanman1
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2011
Quote:
Originally Posted by Steve-x View Post
Sounds like you downloaded the Verizon Dev edition firmware and not the tmobile, I'd download it again.
Thanks for the reply but I'm positive I downloaded

MOTO X, GSM Dev Edition:

KK 4.4-13.11.1Q2.X-69-3_MR2 (Retail)

Which is TMO_RETAIL_XT1053_4.4-13.11.1Q2.X-69-3_MR2_1FF.xml.zip. I triple checked and it's fine on the 1st boot, it only changes on subsequent boots.
 
ghstudio
Old
#4  
Member
Thanks Meter 5
Posts: 42
Join Date: Dec 2013
Quote:
Originally Posted by lanman1 View Post
Thanks for the reply but I'm positive I downloaded

MOTO X, GSM Dev Edition:

KK 4.4-13.11.1Q2.X-69-3_MR2 (Retail)

Which is TMO_RETAIL_XT1053_4.4-13.11.1Q2.X-69-3_MR2_1FF.xml.zip. I triple checked and it's fine on the 1st boot, it only changes on subsequent boots.
I'm not sure that a full restore image changes the boot logo screens. If your phone works on your network, then maybe all you have to do is change the boot loader image(s) which are just graphics and have nothing to do with what the phone is running..
 
lanman1
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2011
Default Help with changing carriers

Quote:
Originally Posted by ghstudio View Post
I'm not sure that a full restore image changes the boot logo screens. If your phone works on your network, then maybe all you have to do is change the boot loader image(s) which are just graphics and have nothing to do with what the phone is running..
I can try redoing the bootloader in fastboot, funny thing is it boots correctly the 1st time. It's almost like the OS thinks it's a non standard bootloader and rewrites it.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes