App Review: Calculating Your Android Calculator Options

Sure, everyone has a default Calculator and its something that you dont think about … more

MultiROM Once Again Available for the Galaxy S4

Multiboot, or the ability to select betweenmultiple operating systems on a single device at … more

Build an Impractical But Awesome Lego Mindstorm Dock

The vast majority of what we cover here on the XDA-Developers News Portal relates to … more

MultiROM Makes its Way Over to the HTC One (M8)

While browsing our forum, you will undoubtedly find more than a few enticing ROMs available … more
Post Reply

[Q] NEED HELP!!! moto x screen went black and is unresponsive

17th January 2014, 08:41 PM   |  #1  
OP Member
Thanks Meter: 7
 
84 posts
Join Date:Joined: Aug 2012
can somebody please help me? my screen just went black at work today and it does nothing at all now. if I hold the power button it vibrates once. if I hold power+volume down I get to recovery. I tried to reboot from there and I get the unlocked bootloader warning screen and from there it just goes to a black screen. so I get back to recovery and installed my back up and that didn't help at all. somebody please help me.
17th January 2014, 08:51 PM   |  #2  
Senior Member
Langley, BC
Thanks Meter: 176
 
572 posts
Join Date:Joined: Sep 2013
So the bootloader is unlocked, what else have you done to the phone?

You may need to reflash it with rsdlite.
17th January 2014, 08:55 PM   |  #3  
Senior Member
Thanks Meter: 127
 
774 posts
Join Date:Joined: Apr 2008
OP you need to provide more details. are you getting the M logo? is it bootlooping? is the phone doing ANYTHING but getting in to recovery?

load the fastboot menu and use mfastboot to flash the system, boot and recovery images. you should be able to bring the phone back to life without losing data.
17th January 2014, 09:21 PM   |  #4  
OP Member
Thanks Meter: 7
 
84 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by 640k

OP you need to provide more details. are you getting the M logo? is it bootlooping? is the phone doing ANYTHING but getting in to recovery?

load the fastboot menu and use mfastboot to flash the system, boot and recovery images. you should be able to bring the phone back to life without losing data.

Im not getting the M logo. Not bootlooping. just get the warning bootloader unlocked screen. sits there for 10 seconds or so and then screen goes black. that's it.

to flash the system, boot, and recovery images. am I getting those form here:http://forum.xda-developers.com/show....php?t=2452246
17th January 2014, 09:22 PM   |  #5  
OP Member
Thanks Meter: 7
 
84 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by jeb192004

Im not getting the M logo. Not bootlooping. just get the warning bootloader unlocked screen. sits there for 10 seconds or so and then screen goes black. that's it.

to flash the system, boot, and recovery images. am I getting those form here:http://forum.xda-developers.com/show....php?t=2452246

just downloaded and opened that up. I don't think that's it....
17th January 2014, 09:25 PM   |  #6  
OP Member
Thanks Meter: 7
 
84 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by Steve-x

So the bootloader is unlocked, what else have you done to the phone?

You may need to reflash it with rsdlite.

the only thing ive done to the phone is put xposed framework on it and gravity box. that was prob a month ago tho. this is the first prob ive had with the phone.
17th January 2014, 09:49 PM   |  #7  
Senior Member
Langley, BC
Thanks Meter: 176
 
572 posts
Join Date:Joined: Sep 2013
You may want to follow this guide to return the phone to stock firmware:

http://forum.xda-developers.com/show....php?t=2446515

You could also try commenting out the line that overwrites user data so you don't lose your data.
17th January 2014, 10:03 PM   |  #8  
Senior Member
Thanks Meter: 101
 
502 posts
Join Date:Joined: Mar 2010
Try plugging your phone into the original charger and then boot to recovery, from their try rebooting while still plugged in. If that doesn't work try this again but wipe just the caches and reboot while plugged in. I have had a screen go black before on other devices and plugging the original charger(car and most others didn't work) in and booting to recovery then rebooting would get it working again.

PS When you boot to recovery check your battery level.
17th January 2014, 10:03 PM   |  #9  
OP Member
Thanks Meter: 7
 
84 posts
Join Date:Joined: Aug 2012
well...I used the moto x toolkit and returned to stock using that. everything booted up. so far everything is looking good. lost all my data but that's not that big of a deal.
3rd August 2014, 08:18 AM   |  #10  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by 640k

OP you need to provide more details. are you getting the M logo? is it bootlooping? is the phone doing ANYTHING but getting in to recovery?

load the fastboot menu and use mfastboot to flash the system, boot and recovery images. you should be able to bring the phone back to life without losing data.

Well im with the same problem but i got the M logo and is not stuck in bootlooping.... right after the boot it goes black...

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank