Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Need help rooting.

OP pianoman674

9th February 2014, 11:39 PM   |  #1  
OP Junior Member
Flag Iowa City
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2011
More
UPDATE:

So I'm trying the reddit instructions again, and I'm making more progress than before. Here's where I'm at now: Everything works flawlessly until I get to step 19. I get a message saying "can't create /sys/kernel/uevent_helper: Permission denied" and my phone never reboots. I've browsed through the comments there and everyone else who gets hung up there just repeats previous steps and has it work (which I've tried) or can't remember how they got it to work. I thought I'd reach out here and see if anyone has any suggestions now.

==================================================

Hey everyone, I've been desperately trying to root my Moto X and I just can't get it to work. I ordered mine about a week ago and I've spent the last two days tinkering away with no success. I've rooted my Droid X and my Droid Razr Maxx in the past, so I would say I have a moderate level of understanding, but I'm stumped by this one.

I tried going the easy route using the Moto X Root Script but it continuously failed for me. I would have posted there, but unfortunately since I'm not the most active user, I haven't even made it to the 10 posts mark so I'm not allowed to... so then I took to the internet and used these instructions I found on Reddit to run through RockMyMoto manually followed by MotoWpNoMoto. I successfully achieved root on 4.2.2 and then accepted the OTA to move to KitKat. However, my phone went into a boot loop and I couldn't get it to respond to anything, so I flashed back to 4.2.2 to try running through the process again. Now, I can't get it to root on 4.2.2 anymore, and I'm not sure what's going wrong.

MotoWpNoMoto does tell me that write protection is already removed, but I'm still not getting anywhere. After flashing back to a clean 4.2.2, I try running the first part of SlapMyMoto, and it says it's all successful, but then when I accept the OTA and try to proceed to the second part of it where you push install.sh, I get an error saying "Install script failed! You received a Permission Denied error while attempting to load the install script into the UEVENT_HELPER. This means that root was not successfully obtained." If I try downloading SuperSU from the marketplace, it tells me no SU binary is installed and the SuperSU can't install it.

Does anyone have any ideas on where to go from here?
Last edited by pianoman674; 10th February 2014 at 01:51 AM.
9th February 2014, 11:49 PM   |  #2  
flashallthetime's Avatar
Senior Member
Flag Richmond Hill
Thanks Meter: 1,299
 
3,784 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by pianoman674

Hey everyone, I've been desperatley trying to root my Moto X and I just can't get it to work. I ordered mine about a week ago and I've spent the last two days tinkering away with no success. I've rooted my Droid X and my Droid Razr Maxx in the past, so I would say I have a moderate level of understanding, but I'm stumped by this one.

I tried going the easy route using the Moto X Root Script but it continuously failed for me. I would have posted there, but unfortunately since I'm not the most active user, I haven't even made it to the 10 posts mark so I'm not allowed to... so then I took to the internet and used these instructions I found on Reddit to run through RockMyMoto manually followed by MotoWpNoMoto. I successfully achieved root on 4.2.2 and then accepted the OTA to move to KitKat. However, my phone went into a boot loop and I couldn't get it to respond to anything, so I flashed back to 4.2.2 to try running through the process again. Now, I can't get it to root on 4.2.2 anymore, and I'm not sure what's going wrong.

MotoWpNoMoto does tell me that write protection is already removed, but I'm still not getting anywhere. After flashing back to a clean 4.2.2, I try running the first part of SlapMyMoto, and it says it's all successful, but then when I accept the OTA and try to proceed to the second part of it where you push install.sh, I get an error saying "Install script failed! You received a Permission Denied error while attempting to load the install script into the UEVENT_HELPER. This means that root was not successfully obtained." If I try downloading SuperSU from the marketplace, it tells me no SU binary is installed and the SuperSU can't install it.

Does anyone have any ideas on where to go from here?

I we to assume you have a consumers version and not the developer edition?

Sent on my Gummy running Lenoto X
9th February 2014, 11:51 PM   |  #3  
OP Junior Member
Flag Iowa City
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2011
More
Quote:
Originally Posted by flashallthetime

I we to assume you have a consumers version and not the developer edition?

Sent on my Gummy running Lenoto X

That is correct, sorry I forgot to put that in there.

32 GB Consumer on Verizon, Came with KitKat preinstalled.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes