Zooper Widget! Create Anything
Post Reply

[Q] Caller ID always shows Unknown

OP ibr4him

27th December 2013, 10:59 AM   |  #1  
OP Senior Member
Thanks Meter: 1
 
125 posts
Join Date:Joined: Dec 2010
Since there is no forum for "Moto G" I'm posting my question here...

All calls from unsaved number only show "Unknown" not even the number of the caller, I badly need a fix for this. I'm on stock ROM and kernel, untouched. I did installed Truecaller and thought that might be causing it, but uninstalling it didn't help.

Does anyone else have the same problem? Any fix for it?

Thanks
27th December 2013, 01:38 PM   |  #2  
Senior Member
Thanks Meter: 17
 
163 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by ibr4him

Since there is no forum for "Moto G" I'm posting my question here...

All calls from unsaved number only show "Unknown" not even the number of the caller, I badly need a fix for this. I'm on stock ROM and kernel, untouched. I did installed Truecaller and thought that might be causing it, but uninstalling it didn't help.

Does anyone else have the same problem? Any fix for it?

Thanks

For future reference the moto g forum does exist : http://forum.xda-developers.com/moto-g

As for your problem, is this also the case when you check the call log? Or only while the call is taking place
27th December 2013, 01:40 PM   |  #3  
OP Senior Member
Thanks Meter: 1
 
125 posts
Join Date:Joined: Dec 2010
No, just incoming calls...they show as "unknown" and no number in the call log as well.
27th December 2013, 03:13 PM   |  #4  
Senior Member
Thanks Meter: 113
 
497 posts
Join Date:Joined: Dec 2010
Donate to Me
More
What carrier are you on? I seem to remember reading somewhere (may not have been here) that a Canadian carrier was charging for Caller ID and shows all calls as unknown even if they are saved in your phone.
17th April 2014, 05:04 AM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2014
Smile
Quote:
Originally Posted by ibr4him

No, just incoming calls...they show as "unknown" and no number in the call log as well.

If you're with Verizon, try this. Login to your account on Verizon's website. Look for the option to change the features of your phone. It should say that Caller ID is ACTIVE for your account. TURN IT OFF. Wait a bit and then try some test calls. Then, go to the website and turn Caller ID BACK ON. Wait a bit and then try some test calls.

This MAY fix your issue. Even if you're not with Verizon, it's possible this could resolve your issue as well if you try this with your current carrier.

Good luck!
Post Reply Subscribe to Thread

Tags
caller id, moto g
Previous Thread Next Thread
Thread Tools
Display Modes