Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Anyone else have this issue getting the no service icon?

OP bmsimon

21st January 2014, 01:20 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2013
I bought the unlocked GSM Moto X that is rooted and has the bootloader unlocked. ROM is stock 4.4 Kitkat Every time after I shut the phone off, it doesn't have any service when it turns back on. I usually have to shut it off and turn it on a few times and mess with the SIM card. Also, the wi-fi won't turn on, either. It just gets stuck on the 'turning on' message but never actually turns on. It kind of seems like the phone just gets stuck in airplane mode and won't come out of it or something.

The biggest potential problem is that I cut a micro SIM card down to a nano SIM to fit in the Moto X. I use my phone on Straight Talk and they don't have a nano SIM yet. But I don't think the cut SIM card is the issue. The phone came with some T-Mobile SIM card. Even though it doesn't have any service from T-Mobile associated with it, when I put the T-Mobile SIM in, it will show that there is service and wi-fi will work. However, after the phone shuts off and I put the T-Mobile SIM in, it still says no service. Plus, the my cut Straight Talk SIM works perfectly fine until the phone shuts off.

Even though it would make sense that cutting my SIM card would cause this problem, I really don't think that's the case. It seems like it's more of a software issue at this point. Does anyone else have this problem or have any insight?
21st January 2014, 01:25 AM   |  #2  
District's Avatar
Member
Flag Washington
Thanks Meter: 16
 
58 posts
Join Date:Joined: Oct 2010
More
Consider installing the T-Mobile SIM, calling your carrier, asking to activate a new cell phone, and read them the SIM number (it's also on the box's label).
21st January 2014, 01:49 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Apr 2013
Quote:
Originally Posted by District

Consider installing the T-Mobile SIM, calling your carrier, asking to activate a new cell phone, and read them the SIM number (it's also on the box's label).

The problem is that I unlocked the booloader and voided my warranty. So there will be no new phone for me. Plus, I bought it straight from Motorola through the Moto Maker
21st January 2014, 03:15 AM   |  #4  
District's Avatar
Member
Flag Washington
Thanks Meter: 16
 
58 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by bmsimon

The problem is that I unlocked the booloader and voided my warranty. So there will be no new phone for me. Plus, I bought it straight from Motorola through the Moto Maker

Sorry, I said it poorly. Try calling your Carrier, and telling them you wish to activate a new phone on your account. The support person might be able to take the SIM number, you recieved on the SIM that came with your Moto X, and activate that SIM to your account\phone number.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes