Default Kitkat recovery trouble

I recently installed a stock 4.4 image thorugh RSD to my xt1058. Everything is working properly, but I'm not able to install a recovery. tried installing through fastboot in a command window, and while I didn't get any errors and the changes were reflected on my phone's bootloader screen, no recovery is accessable. I've tried several different recoveries, and I've also tried naming my recovery "recovery.img", replacing the recovery in the stock image, and flashing it all through RSD. Which succeeded... But still, no recovery is accessable.

I'm avoiding USB 3 ports and have been using the cable that came with my Moto X which is the only way I was able to get the device to show up in RSD.

My brain has stopped working. There must be something somewhere I've missed.

Some info:
RSD 6.1.4
Fastboot and ADB working, device shows up when pinged through command window. Moto drivers installed and recent (however mfastboot or moto-fastboot has never worked, not sure if these are required or redundant)
Unlocked bootloader (via code from Motorola)
System Version: 140.44.3.ghost_row.Retail.en.US
Tmobile 4.4 stock, stock kernel.

ISSUE RESOLVED on my own conviction. Needed to search through unorganized crap to install mfastboot.
Moto X - XT1058 (thinks it's a 1056) - 4.4 | Samsung Galaxy Tab 3 8" - 4.4.2 | Pebble - v2.0