Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,468 Members 38,095 Now Online
XDA Developers Android and Mobile Development Forum

[Q] LTE connection drops every 30 minutes

Tip us?
 
Henrique Belaz
Old
#1  
Henrique Belaz's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Apr 2013
Location: São Paulo

 
DONATE TO ME
Question [Q] LTE connection drops every 30 minutes

Hello!

I've been facing some problems with my LTE connection using TIM in Brazil. My 4G LTE speeds are great (about 50/50mbps) and the connection is pretty stable with about 40ms ping. I even use it to play online games in my computer, as it's faster than my home network. But recently after getting random disconnects when playing, I started to take notes of the time the connection was lost, and I found out that it disconnects every 30 min (the 4g icon also disappears and appears back in something about 3s). It didn't use to happen 1 or 2 months ago.

Wanted to know if that's a carrier-sided problem or it's my moto x, and if it's the second option, I also would like to know if there's something to bypass this half an hour limit (I believe it's some connection timeout).

Hope you guys can help me out!
 
samwathegreat
Old
#2  
samwathegreat's Avatar
Senior Member
Thanks Meter 1,575
Posts: 1,878
Join Date: Apr 2010

 
DONATE TO ME
Quote:
Originally Posted by Henrique Belaz View Post
Hello!

I've been facing some problems with my LTE connection using TIM in Brazil. My 4G LTE speeds are great (about 50/50mbps) and the connection is pretty stable with about 40ms ping. I even use it to play online games in my computer, as it's faster than my home network. But recently after getting random disconnects when playing, I started to take notes of the time the connection was lost, and I found out that it disconnects every 30 min (the 4g icon also disappears and appears back in something about 3s). It didn't use to happen 1 or 2 months ago.

Wanted to know if that's a carrier-sided problem or it's my moto x, and if it's the second option, I also would like to know if there's something to bypass this half an hour limit (I believe it's some connection timeout).

Hope you guys can help me out!
My guess is carrier-side issue. Nothing you can do about it unless they do something on their end. They probably implemented a tcp or udp timeout of 1800 seconds (30 min).

Call and complain...
Help us keep XDA fun and safe. Please read the RULES, and please respect your fellow members.

Looking for a new carrier? Check out Republic Wireless!
Plans starting at $10 for unlimited talk/text and $25 with unlimited data.
Use this link to save $20. RW is my carrier and I couldn't be happier with them.


I successfully CRACKED the SIM-LOCK on the Sprint XT1056 Moto X. Read about it HERE



Donate to me via BitCoin - 1samwaLJ7EdQFGME1dkUGPFZywUEKnXcT
 
bradg24
Old
#3  
bradg24's Avatar
Senior Member
Thanks Meter 49
Posts: 199
Join Date: Apr 2011
The problem I am having a similar problem on Verizon. I have to tap the airplane mode to get 4g back. It drains my battery searching for signal.

Sent from my XT1060 using Tapatalk
 
Henrique Belaz
Old
#4  
Henrique Belaz's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 24
Join Date: Apr 2013
Location: São Paulo

 
DONATE TO ME
Quote:
Originally Posted by bradg24 View Post
The problem I am having a similar problem on Verizon. I have to tap the airplane mode to get 4g back. It drains my battery searching for signal.

Sent from my XT1060 using Tapatalk
Sometimes I face this too... Mostly when I get home and it gets stuck in EDGE or HSDPA (I get a poor signal here because the tower is 7 floors above my apartment) and I can't get LTE back... I need to select GSM only or WDCMA only, wait for it to connect to the data network itself and then switch back to LTE. That's weird.

My cellphone wasn't doing this kind of thing before (timeout). I remember playing an entire match of League of Legends w/o further problems. Gonna try calling my carrier this week and see what's going on.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes