5,600,429 Members 33,022 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Moto X Audio Quality/Network Issues - Sprint

Tip us?
 
HollyDolly
Old
(Last edited by HollyDolly; 16th January 2014 at 10:30 PM.)
#1  
HollyDolly's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Location: Los Angeles
Unhappy [Q] Moto X Audio Quality/Network Issues - Sprint

Hi everyone.

I'm new here. I belong to other android forums but I'm not finding the help that I need there.

I switched from a Photon 4G recently to a Moto X via the motomaker. I'm on the Sprint network.

I barely had any issues with the Photon 4G. Ever since I've bought the Moto X, I've had one issue after another. The most frustrating one right now is audio quality and network issues.

I've contacted Sprint and they're not having any "new" problems. Compared to my Photon 4G, this phone is awful.

When I talk to people, they don't hear me or say every other word cuts out. I am rarely - if ever - on 4G and have to rely on wifi or just 3G to get by. I've been stranded several times late at night in unfamiliar neighborhoods and can't get an address out of there because the phone cannot connect to Google. It's that bad.

I've done loads of trouble shooting with Sprint and Motorola. In the end, I've had to return 2 Moto X's and I'm on my 3rd (and last) one. I've been in contact with the Motorola engineers. They have asked me a lot of questions about my usage, but have not provided any solutions. I've also sent them links to others on the same phone/network having the same exact issues, but this is not being acknowledged.

I'm wondering if you have come up with some solutions/thoughts on this issue?

I rely heavily on my phone for work/personal use/emails. This phone has handicapped me to the point where I'm ready to jump ship to the Nexus 5 or the LG G2 - both of which I've read have had audio issues as well.

I'm out of idea and at the end of my rope.

Thoughts?
 
someguyatx
Old
#2  
someguyatx's Avatar
Senior Member
Thanks Meter 345
Posts: 1,262
Join Date: Feb 2012
Location: Louisville
Its probably Sprint, these network vision upgrades they are doing are causing problems in many areas with both voice and data service. I suspect the switch to the MotoX may have been a coincidence. Where are you located?

Sent from my XT1060 using Tapatalk
 
HollyDolly
Old
#3  
HollyDolly's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Location: Los Angeles
Quote:
Originally Posted by someguyatx View Post
Its probably Sprint, these network vision upgrades they are doing are causing problems in many areas with both voice and data service. I suspect the switch to the MotoX may have been a coincidence. Where are you located?

Sent from my XT1060 using Tapatalk
But it isn't happening on my Photon 4G every time I switch back to it while waiting for my replacement Moto X. I'm in Los Angeles.

Sent from my XT1056 using Tapatalk
 
HollyDolly
Old
#4  
HollyDolly's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Location: Los Angeles
Anyone?

Sent from my XT1056 using Tapatalk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes