Backup+ Lets You Backup Your App Data on Android Lollipop

Even though Android 5.0 Lollipop hasn’t yet seen its official release, quite … more

TechTalk Compiles All the Android News You Need in One App

If you’re as obsessed with mobile devices as the vast majority of our forum … more

Android App Review: Google Inbox to Improve Your Life – XDA TV

Recently, Google+ exploded with the announcement of Google Inbox, as … more

Damp the LG G3 Thermal Throttling

As our mobile devices grow thinner and more powerfulwith each passing generation, it’s inevitable … more
Post Reply

[Q] Moto X Flash Not Working?

OP pasta1234

28th February 2014, 10:05 AM   |  #1  
OP Senior Member
Thanks Meter: 2
 
129 posts
Join Date:Joined: Apr 2011
Hello folks,

I just noticed that my camera app flash and flashlight app don't work. No matter what options are selected the LED wont come on

Is there anything should look into before I call them and assume its a hardware failure?

Thanks,
Pete
28th February 2014, 03:44 PM   |  #2  
Senior Member
Thanks Meter: 34
 
144 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by pasta1234

Hello folks,

I just noticed that my camera app flash and flashlight app don't work. No matter what options are selected the LED wont come on

Is there anything should look into before I call them and assume its a hardware failure?

Thanks,
Pete

If you have the tools and are comfortable with it, remove the back and see if the ribbon cable for the flash is correctly installed. Otherwise, you'll need to do a warranty claim through Motorola. Regular white and black Xs you can get from the carrier, but I'm not a fan of refurbs, so I use the manufacturer's warranty at all times when available.
28th February 2014, 09:18 PM   |  #3  
Senior Member
Thanks Meter: 35
 
241 posts
Join Date:Joined: Jun 2010
More
You could try a factory reset first just to be sure, but it sounds like its a hardware problem.

The flash seems like it is an easy thing to replace, some of the replacement backs available on ebay come with them too, so maybe get a wood or different color back for cheap at the same time if you are gonna do it yourself.

Good luck
-Another Pete
1st March 2014, 12:43 AM   |  #4  
OP Senior Member
Thanks Meter: 2
 
129 posts
Join Date:Joined: Apr 2011
I appreciate all the advice guys...I went ahead and called Moto Support, all they could do was have it sent for evaluation and possible repair since its still under warranty. I tried to offer a credit card as collateral for a new device but they wouldn't go for it...

Not really interested in doing it myself since its only 3 months old, never dropped or anything, very frustrating.

Does anyone have experience with Moto's turn around time ? This is my primary phone not sure how i am going to do this

Pete
1st March 2014, 08:00 PM   |  #5  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by pasta1234

I appreciate all the advice guys...I went ahead and called Moto Support, all they could do was have it sent for evaluation and possible repair since its still under warranty. I tried to offer a credit card as collateral for a new device but they wouldn't go for it...

Not really interested in doing it myself since its only 3 months old, never dropped or anything, very frustrating.

Does anyone have experience with Moto's turn around time ? This is my primary phone not sure how i am going to do this

Pete

Weird, my Moto X led flash isn't working either. I've had it only a couple weeks, and it worked fine initially, but now it's not. I also haven't dropped it or anything. I wonder if it is a common issue.
1st March 2014, 08:47 PM   |  #6  
OP Senior Member
Thanks Meter: 2
 
129 posts
Join Date:Joined: Apr 2011
Very Weird, maybe some update screwed something up ?

Does anyone know if there is a way of enabling the LED without the use of the typical apps to verify if its working ?

Pete


Quote:
Originally Posted by sosleadgtr

Weird, my Moto X led flash isn't working either. I've had it only a couple weeks, and it worked fine initially, but now it's not. I also haven't dropped it or anything. I wonder if it is a common issue.

11th March 2014, 01:29 AM   |  #7  
OP Senior Member
Thanks Meter: 2
 
129 posts
Join Date:Joined: Apr 2011
Just as an update, I took my phone inside the dry sauna and the flash worked, perhaps the heat had something to do with it.. Definitely not a software issue now.

As soon as it cooled off the, the flash stopped working again.

I've filed a repair claim, let's see what happens now..

Pete

Sent from my XT1053 using xda app-developers app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank