Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,303 Members 53,291 Now Online
XDA Developers Android and Mobile Development Forum

Moto x MMS problems on ATT?

Tip us?
 
youwonder
Old
#1  
Member - OP
Thanks Meter 5
Posts: 97
Join Date: Dec 2011
Default Moto x MMS problems on ATT?

So, quick backstory:
got my moto x, loved every part of it except the battery life which was in my opinion pretty sub par. Did some looking around, lots of reports of 4.4 ruining battery life for some people.

So I flashed 4.2.2 (the first OTA with camera I think, file name was ATT_XT1058_4.2.2-13.9.0Q2.X-116-X-17-54_CFC_1FF.xml.zip).*

I god damn love this thing now, battery life is superb and everything else is just as good (cept I miss the 4.4 launcher with the fade out nav bars, but oh well).

However today I discovered a problem. I can't send or receive pictures (more generally anything mms it seems). I've got signal (LTE, more specifically), and SMS/calls work fine.

Tried having a look at the APN settings, but it wont let me edit them anyway, they're greyed out.

That more or less leaves me out of ideas, anyone familiar with this problem?


*I had a hell of a time getting the flash to work. rsdlite 6.1.5 kept giving me an error "unknown adb command: getvar". some googling led to deleting this line in the .xml file
<step operation="getvar" var="max-download-size" />
after which it worked, but then rsdlite got to the "rebooting" phase and hung there. the phone rebooted and was working fine and like hey dude set me up we're good, so I just unplugged it and went.
 
youwonder
Old
#2  
Member - OP
Thanks Meter 5
Posts: 97
Join Date: Dec 2011
wondering if maybe taking the 4.4 OTA update would fix it, though if it causes my battery life to suffer again that'll suck.
 
brian Marshall
Old
#3  
Senior Member
Thanks Meter 27
Posts: 125
Join Date: Mar 2012
If the APN settings are wrong you can create a new one rather than changing the old one.
The Following User Says Thank You to brian Marshall For This Useful Post: [ Click to Expand ]
 
shkrmkr
Old
#4  
Member
Thanks Meter 10
Posts: 36
Join Date: Oct 2010
Location: Champaign, IL
I'm using the T-Mobile variant on AT&T and had trouble sending/receiving MMS when I first got up and running. Had 4G LTE, everything worked, except MMS.

Create a new APN setting as the previous poster suggested. Could be all you need to do is change the MMS port to '8080' instead of '80'. These are my APN settings that work for me:

Name: AT&T PHONE
APN: phone
Proxy: Not Set
Port: Not Set
Username: Not Set
Password: Not Set
Server: Not Set
MMSC: http://mmsc.mobile.att.net
MMS Proxy: proxy.mobile.att.net
MMS port: 8080
MCC: 310
MNC: 410
Authentication Type: Not Set
APN type: default,supl,mms,hipri
APN protocol: IPv4
APN roaming protocol: IPv4
Bearer: Unspecified
MVNO type: None

Like I said, with these settings, I have no issues with MMS and get 4G LTE.
The Following User Says Thank You to shkrmkr For This Useful Post: [ Click to Expand ]
 
youwonder
Old
(Last edited by youwonder; 13th January 2014 at 07:03 PM.)
#5  
Member - OP
Thanks Meter 5
Posts: 97
Join Date: Dec 2011
Thanks for the advice guys. Sadly I can't seem to do...anything actually, related to apns. The existing ones are greyed out when I click on them, and while I can make a new one, it won't save, I click save and nothing happens, back button won't work and when I go back into the menu via settings its not there


Any suggestions?


Edit: I made one with a bogus name and then it let me save it, I've since changed it to match the settings offered here (thank you) but still no dice
 
youwonder
Old
#6  
Member - OP
Thanks Meter 5
Posts: 97
Join Date: Dec 2011
So turns out hangouts has its own APN settings menu for MMS. Changed the port in there to 8080 and now it works.feel kinda silly bit hey at least its good now lol.

Thanks guys
 
shkrmkr
Old
#7  
Member
Thanks Meter 10
Posts: 36
Join Date: Oct 2010
Location: Champaign, IL
Quote:
Originally Posted by youwonder View Post
So turns out hangouts has its own APN settings menu for MMS. Changed the port in there to 8080 and now it works.feel kinda silly bit hey at least its good now lol.

Thanks guys
Awesome man. That was one of the first tricks i tried -- just changing the port to 8080. Once you create a new APN setting, there's a radio button you have to highlight on the right side to select it. it's kind of hard to see, if you can even see it at all. Perhaps that's why you thought you couldn't save it? Either way, glad you found an alternative fix for yourself within hangouts.

The Following User Says Thank You to shkrmkr For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes