Post Reply

[Q] Moto X can't be rerooted?

OP SPACE-AGE-INC

14th February 2014, 08:26 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
18 posts
Join Date:Joined: Feb 2014
More
As for the Moto X my issue seems isolated. Heres what happened.

1.After successfully gaining root access on 4.4, I notice one big problem. My touchless control wouldn't activate via saying ok google now unless I was google search. I tried everything I could to get it to work (check my recent post) but going back to 4.2.2 to re-slapmymoto was the only option.

2.Flashed to 4.2.2 using RSD Lite. Good news is touchless control worked again. Now the disappointing news...

3.Before slapping I wanted to see what was lost and what stuck after flashing, so I checked my write protection. It came back '0'. Check for root access, it showed su: not found or in other words, not rooted.

4.I was going through the rockmymoto process then hit a snag. After entering the dalvikvm code into puttytel/telnet, it took me straight to step 3 and did absolutely nothing (see picture). I waited for 1min anyways and checked root again...no dice. Adb rebooted the device, reconnected to puttytel and checked again...nothing.

I've searched for about 4hrs straight trying to figure this out. Is there really no way to root again???

Verizon Moto X (currently 4.2.2)
Attached Thumbnails
Click image for larger version

Name:	IMG_20140214_021207191_HDR.jpg
Views:	1212
Size:	252.6 KB
ID:	2578532  
14th February 2014, 09:00 AM   |  #2  
Senior Member
Thanks Meter: 743
 
2,924 posts
Join Date:Joined: Nov 2009
I've been reading that if you downgrade to 4.2.2 then receive OTA update you will brick the phone, be careful.

sent via tapatalk
14th February 2014, 09:45 AM   |  #3  
Senior Member
Flag Everywhere
Thanks Meter: 294
 
503 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by SPACE-AGE-INC

As for the Moto X my issue seems isolated. Heres what happened.

1.After successfully gaining root access on 4.4, I notice one big problem. My touchless control wouldn't activate via saying ok google now unless I was google search. I tried everything I could to get it to work (check my recent post) but going back to 4.2.2 to re-slapmymoto was the only option.

2.Flashed to 4.2.2 using RSD Lite. Good news is touchless control worked again. Now the disappointing news...

3.Before slapping I wanted to see what was lost and what stuck after flashing, so I checked my write protection. It came back '0'. Check for root access, it showed su: not found or in other words, not rooted.

4.I was going through the rockmymoto process then hit a snag. After entering the dalvikvm code into puttytel/telnet, it took me straight to step 3 and did absolutely nothing (see picture). I waited for 1min anyways and checked root again...no dice. Adb rebooted the device, reconnected to puttytel and checked again...nothing.

I've searched for about 4hrs straight trying to figure this out. Is there really no way to root again???

Verizon Moto X (currently 4.2.2)


Lol,you won't brick.

To get phone rooted again since you already have write protection turned off, just use slapmymoto instead of rockmymoto. I know you said you were on 4.2.2 but the write protection turned off will not let rockmymoto complete.

Good luck and hope this helps!
The Following 2 Users Say Thank You to Klown80 For This Useful Post: [ View ]
14th February 2014, 10:43 AM   |  #4  
OP Junior Member
Thanks Meter: 1
 
18 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by eksasol

I've been reading that if you downgrade to 4.2.2 then receive OTA update you will brick the phone, be careful.

sent via tapatalk

Quote:
Originally Posted by Klown80

Lol,you won't brick.

To get phone rooted again since you already have write protection turned off, just use slapmymoto instead of rockmymoto. I know you said you were on 4.2.2 but the write protection turned off will not let rockmymoto complete.

Good luck and hope this helps!

I love you
8th April 2014, 06:55 PM   |  #5  
drago10029's Avatar
Senior Member
Phazon Mines
Thanks Meter: 79
 
465 posts
Join Date:Joined: Nov 2008
More
Quote:
Originally Posted by SPACE-AGE-INC

I love you

I'm having the exact same problem as OP doing the exact same thing WP 0 etc.. I used SlapMYMoto, after the reboot on step 2 I waited about 5 minutes installed Supersu and same error OP was getting, thoughts?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank