Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Moto X (NOT ROOTED) - Wifi and Bluetooth problems

OP rafaelrossignoli

5th October 2014, 03:23 AM   |  #11  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
Cloud Search crappy wifi
Quote:
Originally Posted by rafaelrossignoli


Update: sending my Moto x warranty. Tell you what was wrong when I get it back

Have you managed to get an update? I think I am having the same exact problems.
Not a developer device so can't unlock the bootloader
Not rooted. \persist\ is empty if that would make any difference at all.
Surprisingly once when I restarted the phone in bptools menu options on the boot menu, the phone came up fine and I was able to turn on my wifi and bluetooth. After about 10 minutes, the phone restarted on it's own and ever since they won't turn on.
Did a full wipe, FDR and also wiped cache but still the same now. Booting using BPTools menu option doesn't help any more.

For the last couple weeks, my phone is just guzzling data on 4G. Having a wifi would help. Please don't suggest me to do a warranty repair That is what I might end up doing in about two weeks. The unlocked device was bought in India but I am now abroad.
Using XT1052 running Kitkat 4.4.4 - AsiaRetail.
5th October 2014, 04:04 AM   |  #12  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by mutukrp

Have you managed to get an update? I think I am having the same exact problems.
Not a developer device so can't unlock the bootloader
Not rooted. \persist\ is empty if that would make any difference at all.
Surprisingly once when I restarted the phone in bptools menu options on the boot menu, the phone came up fine and I was able to turn on my wifi and bluetooth. After about 10 minutes, the phone restarted on it's own and ever since they won't turn on.
Did a full wipe, FDR and also wiped cache but still the same now. Booting using BPTools menu option doesn't help any more.

For the last couple weeks, my phone is just guzzling data on 4G. Having a wifi would help. Please don't suggest me to do a warranty repair That is what I might end up doing in about two weeks. The unlocked device was bought in India but I am now abroad.
Using XT1052 running Kitkat 4.4.4 - AsiaRetail.

For first, thank you for reminding me about this thread. I bring bad news for you, unfortunately. It's 99% a hardware failure. In my case, it really was one. After 25 days, my phone was back from warranty with a new wifi/bluetooth hardware.

My phone was behaving the same way as yours. Sometimes the wifi was back working for a while, then my phone restarted and wifi was unavailable again. So, i recommend you send your phone warranty as soon as possible. Good luck!
7th October 2014, 11:36 PM   |  #13  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
Unhappy
Quote:
Originally Posted by rafaelrossignoli

So, i recommend you send your phone warranty as soon as possible. Good luck!

Well, I don't think I really have a choice here. I would be able to give my device for service only in about another 2 weeks so I have to live with 4G! I'll let you know how it goes. And thanks for the update...
18th October 2014, 08:05 PM   |  #14  
Junior Member
Thanks Meter: 1
 
1 posts
Join Date:Joined: Oct 2014
wifi and bluetooth not turning On FIX
Hello everybody.i use a moto x (xt1052) 4.4.4 kitkat not rooted.
A week ago started having problems with wifi communication not turning on and a couple of days later bluetooth couldnt locate any connections
I fixed these problems by switching to ART Runtime from the developer settings.this will reboot your phone and starts upgrading your apps .after that wifi and bluetooth work fine .(for now..)
I am also wondering if anyone has any random reboots or its just my pocket..

Hope it helps for you too.
Cheers,Stelios

Updated: WiFi and Bluetooth stopped working again.leaning more on software issue than hardware.
Last edited by are.petrakis; 18th October 2014 at 11:11 PM.
The Following User Says Thank You to are.petrakis For This Useful Post: [ View ]
19th October 2014, 06:04 PM   |  #15  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
Smile
Quote:
Originally Posted by are.petrakis

I fixed these problems by switching to ART Runtime from the developer settings.this will reboot your phone and starts upgrading your apps .after that wifi and bluetooth work fine .(for now..)

Updated: WiFi and Bluetooth stopped working again.leaning more on software issue than hardware.

Nope, that didn't help me at all. I think at least my issue is hardware related. Giving the phone for warranty repair on Thursday, let's see what happens.
4th November 2014, 01:03 PM   |  #16  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Dec 2012
Update
Been to the service center a week ago. Apparently the moment I explained my issue, they said it is an hardware issue and so the board needs a replacement. Got my phone back and it has been a week with no issues. Fingers crossed...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes