Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Moto X T-Mobile Dev: sp space not enough error

OP jerryclho

19th March 2014, 11:10 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2011
My phone is a T-Mobile DEV Moto x. Unlocked bootloader. Have been flash with the 4.4.2 rom of ROGER and Retailed Taiwan.
After flashed with Retailed Taiwan, I flash it back to T-Mobile 4.4.2 and get this 'sp space not enough error' when flashing the system (fastboot flash system system.img). My phone can boot fine with the T-Mobile 4.4.2 system.
I redo the whole flash process as below:
SET fastboot=fastboot.exe
%fastboot% getvar max-download-size
%fastboot% oem fb_mode_set
%fastboot% flash partition gpt.bin
%fastboot% flash motoboot motoboot.img
%fastboot% flash logo logo.bin
%fastboot% flash boot boot.img
%fastboot% flash recovery recovery.img
%fastboot% flash system system.img
%fastboot% flash modem NON-HLOS.bin
%fastboot% erase modemst1
%fastboot% erase modemst2
%fastboot% flash fsg fsg.mbn
%fastboot% erase cache
%fastboot% erase userdata
%fastboot% erase customize
%fastboot% erase clogo
%fastboot% oem fb_mode_clear
pause
Still get the same error when flashing the system. I can backup and restore the system with TWRP recovery without any problem.
Should it be concerned? How can I get rid of this error?
19th March 2014, 04:20 PM   |  #2  
Senior Member
Flag Fort Myers,FL
Thanks Meter: 238
 
571 posts
Join Date:Joined: Jul 2009
More
Quote:
Originally Posted by jerryclho

My phone is a T-Mobile DEV Moto x. Unlocked bootloader. Have been flash with the 4.4.2 rom of ROGER and Retailed Taiwan.
After flashed with Retailed Taiwan, I flash it back to T-Mobile 4.4.2 and get this 'sp space not enough error' when flashing the system (fastboot flash system system.img). My phone can boot fine with the T-Mobile 4.4.2 system.
I redo the whole flash process as below:
SET fastboot=fastboot.exe
%fastboot% getvar max-download-size
%fastboot% oem fb_mode_set
%fastboot% flash partition gpt.bin
%fastboot% flash motoboot motoboot.img
%fastboot% flash logo logo.bin
%fastboot% flash boot boot.img
%fastboot% flash recovery recovery.img
%fastboot% flash system system.img
%fastboot% flash modem NON-HLOS.bin
%fastboot% erase modemst1
%fastboot% erase modemst2
%fastboot% flash fsg fsg.mbn
%fastboot% erase cache
%fastboot% erase userdata
%fastboot% erase customize
%fastboot% erase clogo
%fastboot% oem fb_mode_clear
pause
Still get the same error when flashing the system. I can backup and restore the system with TWRP recovery without any problem.
Should it be concerned? How can I get rid of this error?

you need to use mfastboot for the system

Code:
fastboot flash partition gpt.bin
fastboot flash motoboot motoboot.img
fastboot flash logo logo.bin
fastboot flash boot boot.img
fastboot flash recovery recovery.img
mfastboot flash system system.img
fastboot flash modem NON-HLOS.bin
fastboot erase modemst1
fastboot erase modemst2
fastboot flash fsg fsg.mbn
fastboot erase userdata
fastboot erase cache

fastboot reboot
if you need the mfastboot file check out this thread and look at the returning to stock section it has a link for mfastboot

http://forum.xda-developers.com/moto...uides-t2603358
20th March 2014, 03:43 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2011
Thanks for the input.
Yes, I flash the system with mfastboot and get this error.
At PC side, no error and the writing finished without error. The error only showed at the phone.
This happened after I flashed the 4.4.2 RetailTaiwan(Blur_Version.161.44.34.ghost_row.Asia Retail.en.03)
I just wonder could this caused by the new bootloader of RetailTaiwan 4.4.2?
My bootloader ver 30.B4
Last edited by jerryclho; 20th March 2014 at 08:03 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes