FORUMS

OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

Make Your Lockscreen More Productive With Widgets

Are you running Android Lollipop? Do you miss the ability to add widgets to your lock … more

[Q] [Moto X XT1060] Issues with WiFi and Bluetooth.

15 posts
Thanks Meter: 5
 
By FleetPhone, Junior Member on 12th July 2014, 02:12 AM
Post Reply Subscribe to Thread Email Thread
3rd April 2015, 10:10 PM |#21  
Junior Member
Flag Mexico
Thanks Meter: 2
 
More
Question
Quote:
Originally Posted by marin1577

I Have XT 1058 device and I've got same WiFI issues(4.4.2). In my /persist folder have:

Prov(folder)
usf(folder)

.bt_nv.bin
WCNSS_qcom_wlan_nv.bin
WCNSS_qcom_wlan_nv_calibration_persist.bin
WCNSS_qcom_wlan_nv_regulatory_persist.bin


The problem is, the last 2 files in the list, have a size of 0.00 B
I Have replaced them with the files provided from samwathegreat(and following the -rw-r--r-- permissions), but when i restart or shutdown, the files appears as if i havenīt done any change (0.00 B Size again)

I also replace WCNSS Files(except cfg.dat and cfg.ini) on system/etc/firmware/wlan/prima with the ones provided, 3 of them had 0.00 Size, but fortunately the changes persists after reboots or shuwtdown.


I'll really appreciate your help, sorry for my awfull english

I have exactly the same problem and did like you do, but nothing changes. i've changed one by one the files, and i've changed permissions. If someone can give us a clue, would be really apreciated.
 
 
6th April 2015, 08:19 PM |#22  
marin1577's Avatar
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by kevshocks

I have exactly the same problem and did like you do, but nothing changes. i've changed one by one the files, and i've changed permissions. If someone can give us a clue, would be really apreciated.

I'm still with the WiFi issues, try to connect some 5Ghz Network, at least i can. I'll keep trying with WCNSS Files and i'll post here if i find the solution
1st June 2015, 04:19 PM |#23  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by marin1577

I Have XT 1058 device and I've got same WiFI issues(4.4.2). In my /persist folder have:

Prov(folder)
usf(folder)

.bt_nv.bin
WCNSS_qcom_wlan_nv.bin
WCNSS_qcom_wlan_nv_calibration_persist.bin
WCNSS_qcom_wlan_nv_regulatory_persist.bin


The problem is, the last 2 files in the list, have a size of 0.00 B
I Have replaced them with the files provided from samwathegreat(and following the -rw-r--r-- permissions), but when i restart or shutdown, the files appears as if i havenīt done any change (0.00 B Size again)

I also replace WCNSS Files(except cfg.dat and cfg.ini) on system/etc/firmware/wlan/prima with the ones provided, 3 of them had 0.00 Size, but fortunately the changes persists after reboots or shuwtdown.


I'll really appreciate your help, sorry for my awfull english

hey marin
can you post the step by step of this procedure and what need to be downloaded. because i'm have same problems and i'm newbie of doing this. I did root my moto x by looking the youtube.

thanks
7th June 2015, 01:27 PM |#24  
Junior Member
Thanks Meter: 0
 
More
All files missing
Quote:
Originally Posted by FleetPhone

Well, first you will need to use a file manager to look inside the persist folder, which is located in the root directory. You must have these 4 files:
.bt_nv.bin
WCNSS_qcom_wlan_nv.bin
WCNSS_qcom_wlan_nv_calibration_persist.bin
WCNSS_qcom_wlan_nv_regulatory_persist.bin

If they are there, you should be fine. If you still have a problem, then this solution is not for you.

hey i read all your comments and replies i found that my moto x xt1052 doesnt have single file of the 4 you mentioned . i could manage downloading the WCNSS_qcom_wlan_nv.bin file but i am unable to find the rest of the files. It would be really helpful of you if you could provide me with the link to those files
21st July 2015, 09:29 PM |#25  
Junior Member
Thanks Meter: 1
 
More
Worked!
Quote:
Originally Posted by samwathegreat

You only have 3 files??? Because my X has 4 files:

.bt_nv.bin
WCNSS_qcom_wlan_nv.bin
WCNSS_qcom_wlan_nv_calibration_persist.bin
WCNSS_qcom_wlan_nv_regulatory_persist.bin

Just as I had said in my very first reply, you are missing WCNSS_qcom_wlan_nv.bin

---------- Post added at 12:47 AM ---------- Previous post was at 12:43 AM ----------

Here: http://forum.xda-developers.com/atta...9&d=1400950032

Download the file, and place JUST the missing file back in /persist

The permissions should be: rw-r--r-- (permissions must be set correctly)

Does WiFi work now??

Followed the procedure and flashed a new stock 5.1 ROM for a moto X and it worked fine ! After a hard brick it had only two linked files on /persist. Bluetooth and wifi were dead with no MAC addresses.

Thanks!!

M.
Yesterday, 07:34 AM |#26  
Junior Member
Thanks Meter: 0
 
More
I have the same problem en I already check the /persist folder and it's OK
The weir thing is tha every time I change my rom in the 4th try the wifi and blutooth works but jut for simething like a 2 hours. I still havenīt found the solution for me and dont want to sell my moto X I like it .
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes