Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Network settings won't work on T-mobile Roaming

OP foxfire235

4th January 2014, 12:56 AM   |  #1  
OP Senior Member
Thanks Meter: 30
 
183 posts
Join Date:Joined: Oct 2009
My brand new Moto X will not work while roaming on t-mobile. This is a bummer because I'm in Alaska and roam on GCI. The problem lies in the network settings. I can't change the "preferred network type" to "3g" like I can on the N5. My only choices are "automatic" and "2g". Can anyone think of a way around this?
4th January 2014, 01:43 AM   |  #2  
Senior Member
Langley, BC
Thanks Meter: 207
 
664 posts
Join Date:Joined: Sep 2013
You can grab an app called "LTE Setting" from the play store, it will allow you to select "WCDMA only" - which is HSPA/3G.
5th January 2014, 01:57 AM   |  #3  
OP Senior Member
Thanks Meter: 30
 
183 posts
Join Date:Joined: Oct 2009
Quote:
Originally Posted by Steve-x

You can grab an app called "LTE Setting" from the play store, it will allow you to select "WCDMA only" - which is HSPA/3G.

Cool! I will try this and report back.
5th January 2014, 04:38 PM   |  #4  
scottjb's Avatar
Senior Member
Flag Greensboro, NC
Thanks Meter: 161
 
895 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by foxfire235

...This is a bummer because I'm in Alaska and roam on GCI. The problem lies in the network settings. I can't change the "preferred network type" to "3g" like I can on the N5. My only choices are "automatic" and "2g"...

Are you sure that's the problem? T-Mobile's Moto X considers HSPA to be 4G. When my T-Mo Moto X switches to HSPA, The 4G icon stays, but the LTE icon goes away. It could be GCI does not use the band(s) the T-Mo phone is equipped to use.
6th January 2014, 07:23 PM   |  #5  
OP Senior Member
Thanks Meter: 30
 
183 posts
Join Date:Joined: Oct 2009
Quote:
Originally Posted by scottjb

Are you sure that's the problem? T-Mobile's Moto X considers HSPA to be 4G. When my T-Mo Moto X switches to HSPA, The 4G icon stays, but the LTE icon goes away. It could be GCI does not use the band(s) the T-Mo phone is equipped to use.

Yep, that's definitely the problem. 3g works great on my iphone, and Nexus 5 but you MUST turn off LTE / 4g in order for it to work. Since the Moto X doesn't have that ability in the software it wasn't working. Seems like the LTE settings app is working well so far.
Post Reply Subscribe to Thread

Tags
alaska, apn, network, roaming, t-mobile
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes