Post Reply

[Q] Can't get past bootloader and can't transfer new files

OP emailrob

28th April 2014, 04:22 AM   |  #1  
OP Member
Thanks Meter: 11
 
78 posts
Join Date:Joined: Nov 2012
X1053, rooted and unlocked bootloader on T Mob US

Tried to install a new kernel but it failed. Wiped cached (factory reset in twrp) and now it won't boot past the animation logo.

As its not booted into the OS, windows won't recognize it as a device so i can't install a new rom to try again. Windows 8 'bings' when I connect it but it won't load as a drive.

I CAN get into AP Fashboot Flash Mode If I then go to Recovery, it still takes me to twrp. But there are not zip files to install that work and I can't work out how to copy them over without windows recognizing the device?

Thanks in advance
28th April 2014, 06:46 AM   |  #2  
KJ's Avatar
XDA: ASSIST
Recognized Contributor
Flag The boonies - southwest Ontario
Thanks Meter: 4,140
 
10,310 posts
Join Date:Joined: May 2011
More
You'll maybe need to flash the same stock firmware version you're on now...4.4 or 4.4.2 or whatever version you were on. Then root again.

This will help you...

http://forum.xda-developers.com/show....php?t=2603358

Good luck!
28th April 2014, 04:01 PM   |  #3  
OP Member
Thanks Meter: 11
 
78 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by kj2112

You'll maybe need to flash the same stock firmware version you're on now...4.4 or 4.4.2 or whatever version you were on. Then root again.

This will help you...

http://forum.xda-developers.com/show....php?t=2603358

Good luck!

Thanks for the reply. the problem is I can't connect to the phone to transfer a new firmware on. It 'bings' on USB plug but won't open as a USB drive. I can't get the phone to boot, can only get it to recovery. i tried reinstalling the motorola drivers again but still no luck.

When it was running Ok, I could plug it in (when it used to load into the android OS OK) and it would appear as a USB drive in Windows 8. I also tried on a different laptop.
29th April 2014, 04:32 AM   |  #4  
Member
Thanks Meter: 28
 
99 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by emailrob

Thanks for the reply. the problem is I can't connect to the phone to transfer a new firmware on. It 'bings' on USB plug but won't open as a USB drive. I can't get the phone to boot, can only get it to recovery. i tried reinstalling the motorola drivers again but still no luck.

When it was running Ok, I could plug it in (when it used to load into the android OS OK) and it would appear as a USB drive in Windows 8. I also tried on a different laptop.

When you boot into bootloader, does the phone itself recognize that it is connected via USB? If so, you have to obtain the current SBF of your phone and flash over the files via fastboot.exe and mfastboot.exe.

There are plenty of guides throughout this site. Take your time and read everything before you make your first move.
29th April 2014, 05:02 AM   |  #5  
OP Member
Thanks Meter: 11
 
78 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by Cyphir

When you boot into bootloader, does the phone itself recognize that it is connected via USB? If so, you have to obtain the current SBF of your phone and flash over the files via fastboot.exe and mfastboot.exe.

There are plenty of guides throughout this site. Take your time and read everything before you make your first move.

OK panic nearly over! I managed to get it flashed using RDS lite. 4.4 is back on now, although I lost my root Not sure I want to go down the whole downgrade to 4.2.2 etc but I'll see. Thanks again
30th April 2014, 05:37 PM   |  #6  
OP Member
Thanks Meter: 11
 
78 posts
Join Date:Joined: Nov 2012
Just adding a reply in case anyone has a similar issue.

RSDLite managed to get the firmware back on. It lost root, but what actually happened is the recovery got deleted / corrupted.

So i went back through the rooting guide which started by adding twrp and then flashing. Rebooted, and SuperSU tells me all is OK and root is there.

30th April 2014, 10:35 PM   |  #7  
Senior Member
Thanks Meter: 100
 
552 posts
Join Date:Joined: Mar 2011
Is your phone recognized by fastboot or adb?

Since your bootloader is unlocked, manually flash the 4.4.2 firmware files, then TWRP, then boot into recovery, use adb to push SuperSU or whichever root program you prefer to /sdcard, then use TWRP to flash it.
30th April 2014, 10:41 PM   |  #8  
OP Member
Thanks Meter: 11
 
78 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by nhizzat

Is your phone recognized by fastboot or adb?

Since your bootloader is unlocked, manually flash the 4.4.2 firmware files, then TWRP, then boot into recovery, use adb to push SuperSU or whichever root program you prefer to /sdcard, then use TWRP to flash it.

Its all working OK now thanks. I just flashed 4.4 again and re-installed TWRP.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank