Post Reply

Problem with flashing

8th July 2014, 05:49 AM   |  #1  
OP Junior Member
Flag San Luis Potosí
Thanks Meter: 1
 
29 posts
Join Date:Joined: Apr 2014
More
Okay, i've wanted to flash TWRP, to flash CM11, so i have root, unlocked bootloader, drivers, etc. Required for flashing but there are two problems.

---DONT MIND THIS, MY FAULT (Solved)---

With TWRP flashing:
* Whenever i try to flash it (i have the file in the adt bundle folder with the cmd window open from the directory) and write:

fastboot flash recovery [filename].img (yes, i've checked many times for typos)

I get this:

(Bootloader) variable not supported

---This is the actual problem---

With Stock flashing:

Then i tried to re-flash stock firmware in case that there were any corrupted file interrupting the process.

Flashed, but in the process, after, or while flashing system.img (All with RSD Lite), in the phone, appeared a red text line that said "sp space is not enough" and the phone took like half a minute to reboot again and everything seemed to be normal. But if i try to do any of those processes again, even if i re flash stock fw, it keeps the same.

Need responses please D:
Last edited by ANMTMS; 8th July 2014 at 06:08 AM.
8th July 2014, 06:13 AM   |  #2  
NWKENT's Avatar
Senior Member
Thanks Meter: 478
 
1,074 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by ANMTMS

Okay, i've wanted to flash TWRP, to flash CM11, so i have root, unlocked bootloader, drivers, etc. Required for flashing but there are two problems.

---DONT MIND THIS, MY FAULT (Solved)---

With TWRP flashing:
* Whenever i try to flash it (i have the file in the adt bundle folder with the cmd window open from the directory) and write:

fastboot flash recovery [filename].img (yes, i've checked many times for typos)

I get this:

(Bootloader) variable not supported

---This is the actual problem---

With Stock flashing:

Then i tried to re-flash stock firmware in case that there were any corrupted file interrupting the process.

Flashed, but in the process, after, or while flashing system.img (All with RSD Lite), in the phone, appeared a red text line that said "sp space is not enough" and the phone took like half a minute to reboot again and everything seemed to be normal. But if i try to do any of those processes again, even if i re flash stock fw, it keeps the same.

Need responses please D:

If I understand your post correctly..

Sir..use mfastboot with this command >>

mfastboot flash recovery recovery.img

Rename your recovery file to this >> recovery.img

Then flash..make sure that the recovery.img file is in the same directory as adb.exe

Make sure that you do have a mfastboot.exe in the same directory as the adb.exe..you may have to also copy some .dll files from another directory to the same directory as the mfastboot.exe (and) adb.exe

Also..you mentioned that you flashed a new OS..maybe the FXZ is modified to NOT erase data/cache.?

Make SURE that you have the proper TWRP version for your device..(probably) "ghost" code name type TWRP is what you'll need..many ones mess up by not using the proper TWRP version for the device..

Sent from my:
(Jaocagomex debloated)
4.4_19.6.3 (Unlocked)
XT1080M Droid Maxx #2
http://waynekent.com/page6.html
Last edited by NWKENT; 8th July 2014 at 06:44 AM.
The Following User Says Thank You to NWKENT For This Useful Post: [ View ]
8th July 2014, 08:12 AM   |  #3  
samwathegreat's Avatar
Senior Member
Thanks Meter: 1,684
 
1,965 posts
Join Date:Joined: Apr 2010
Donate to Me
Quote:
Originally Posted by ANMTMS

Okay, i've wanted to flash TWRP, to flash CM11, so i have root, unlocked bootloader, drivers, etc. Required for flashing but there are two problems.

---DONT MIND THIS, MY FAULT (Solved)---

With TWRP flashing:
* Whenever i try to flash it (i have the file in the adt bundle folder with the cmd window open from the directory) and write:

fastboot flash recovery [filename].img (yes, i've checked many times for typos)

I get this:

(Bootloader) variable not supported

---This is the actual problem---

With Stock flashing:

Then i tried to re-flash stock firmware in case that there were any corrupted file interrupting the process.

Flashed, but in the process, after, or while flashing system.img (All with RSD Lite), in the phone, appeared a red text line that said "sp space is not enough" and the phone took like half a minute to reboot again and everything seemed to be normal. But if i try to do any of those processes again, even if i re flash stock fw, it keeps the same.

Need responses please D:

Find the Return to Stock thread.

Use the manual method instead of RSD Lite, and use 'mfastboot' for ALL commands.

The problem is that the native fastboot cannot flash system.img because it is too large. The modified motorola 'mfastboot' is able to flash it.

Please try and post results.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank