FORUMS

[Q] Sprint Moto-x call quality?

13 posts
Thanks Meter: 5
 
By mymod, Junior Member on 23rd January 2014, 06:57 PM
Post Reply Subscribe to Thread Email Thread
I recently picked up a Sprint moto-x from amazon. Love the phone, but the call quality was just terrible. I experienced a persistent hissing sound whenever the other party spoke, as well as noticeable delay between speaking, and being heard at the other end. This is in contrast to my old Galaxy S2, which performs flawlessly in the same area (Chicago IL). I ended up returning the phone after two days. I am now considering purchasing another unit, just to confirm it was not a defect in the hardware. Has anybody experienced similar issues? Are there any solutions to this problem?
 
 
23rd January 2014, 09:00 PM |#2  
VerneVerne's Avatar
Senior Member
Thanks Meter: 45
 
More
Quote:
Originally Posted by mymod

I recently picked up a Sprint moto-x from amazon. Love the phone, but the call quality was just terrible. I experienced a persistent hissing sound whenever the other party spoke, as well as noticeable delay between speaking, and being heard at the other end. This is in contrast to my old Galaxy S2, which performs flawlessly in the same area (Chicago IL). I ended up returning the phone after two days. I am now considering purchasing another unit, just to confirm it was not a defect in the hardware. Has anybody experienced similar issues? Are there any solutions to this problem?

I'm also on Sprint with a Moto X and haven't noticed any sound issues with calling.
30th January 2014, 07:02 PM |#3  
Senior Member
Thanks Meter: 8
 
More
Quote:
Originally Posted by mymod

I recently picked up a Sprint moto-x from amazon. Love the phone, but the call quality was just terrible. I experienced a persistent hissing sound whenever the other party spoke, as well as noticeable delay between speaking, and being heard at the other end. This is in contrast to my old Galaxy S2, which performs flawlessly in the same area (Chicago IL). I ended up returning the phone after two days. I am now considering purchasing another unit, just to confirm it was not a defect in the hardware. Has anybody experienced similar issues? Are there any solutions to this problem?

I have had the EVO LTE, Galaxy S4 and Moto X all within the last year. I would definitely agree that there is a sound quality issue with the moto x. I think it has to do with a poor quality earpiece speaker. Bluetooth sounds fine, and speakerphone is okayish. The galaxy s4 sounded the best of the three.

That being said. I'm still choosing to use the Moto X over the S4.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes