5,595,570 Members 45,867 Now Online
XDA Developers Android and Mobile Development Forum

[Q] USB OTG not working after RockmyMoto

Tip us?
 
ab.
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 10
Join Date: Feb 2012
Question [Q] USB OTG not working after RockmyMoto

Hi guys, once I've bought my Rogers Moto X , I've rooted my with PwnMyMoto 1.4.3 or Root Version 1.1 ( I couldn't recall which one), and USB OTG was working perfectly.

I then foolishly updated the OTA and then rooted my phone with Rockmymoto to gain access to Root/Write Protection Bypass.

So now my phone is Rooted successfully and got Xposed to work, but USB OTG doesn't work anymore. (I've tried different OTG cables and drives)

I have tried to fix this by using USB Host Diagnostics app results are attached.

I am wonder if anyone have experienced this or know what I am doing wrong.




And as a last resort, can I use RSDlite to flash the stock Rogers firmware even after my camera OTA update?

Any help is much appreciated!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-12-30-03-54-13.png
Views:	195
Size:	87.0 KB
ID:	2483347   Click image for larger version

Name:	Screenshot_2013-12-30-20-52-46.png
Views:	206
Size:	106.9 KB
ID:	2483348  
 
themaker69
Old
#2  
themaker69's Avatar
Member
Thanks Meter 18
Posts: 44
Join Date: Oct 2013
Location: São Paulo
I have the same problem, but it is not the root fault in my case, it's the kitkat OTA update that broke the OTG support. You can see more about this bug googling:
https://forums.motorola.com/posts/83b76002b4
http://forum.xda-developers.com/show...&highlight=otg
http://forum.xda-developers.com/show...&highlight=otg
Defy+[MB526] and Defy[MB525] resources:

SlimROM | GApps | Defy Full Wiper (ext4) | 2ndBoot | SBF/Root/Custom ROM install guide | TWRP
 
ab.
Old
#3  
Junior Member - OP
Thanks Meter 2
Posts: 10
Join Date: Feb 2012
Quote:
Originally Posted by themaker69 View Post
I have the same problem, but it is not the root fault in my case, it's the kitkat OTA update that broke the OTG support. You can see more about this bug googling:
https://forums.motorola.com/posts/83b76002b4
http://forum.xda-developers.com/show...&highlight=otg
http://forum.xda-developers.com/show...&highlight=otg
I am still running on 4.2.2 though.. and the latter two links aren't clickable.
I am wondering if I can go back to stock safely (before camera OTA).
 
Groid
Old
#4  
Senior Member
Thanks Meter 88
Posts: 481
Join Date: May 2010
I didn't root with rockmymoto. I unlocked the bootloader on my Tmo X and flashed TWRP and Supersu to root. I have the 4.4 update and using Stickmount I have full access to OTGusb with flash drives, sd and microsd cards, and my external hd. Maybe something glitchy in the root method for rockmymoto?
 
ab.
Old
#5  
Junior Member - OP
Thanks Meter 2
Posts: 10
Join Date: Feb 2012
Quote:
Originally Posted by Groid View Post
I didn't root with rockmymoto. I unlocked the bootloader on my Tmo X and flashed TWRP and Supersu to root. I have the 4.4 update and using Stickmount I have full access to OTGusb with flash drives, sd and microsd cards, and my external hd. Maybe something glitchy in the root method for rockmymoto?
I don't see others complain about not able to use the USB OTG after rooting their phones with Rockmymoto, so I'm unsure what I messed up.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes