Post Reply

[Q] Verizon Moto X dev problems on T-Mobile

15th June 2014, 05:55 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2014
Hi,

I have a Verizon Moto X Dev. Edition that I would like to use on T-Mobile network. So far I'm only able to get voice and data by disabling LTE and usting H+. Is there a way to use my XT1060 as a XT1053? in other words are the two models hardware different? or can i install the T-Mobile software and my phone so that I can use T-Mobile's LTE and have voice and data?

Thanks in advance for any help.

Best regards,

Rene
15th June 2014, 03:17 PM   |  #2  
KidJoe's Avatar
Senior Member
Flag Thorndale/Romansville, PA
Thanks Meter: 800
 
1,998 posts
Join Date:Joined: Aug 2008
More
Quote:
Originally Posted by Renevasquez

Hi,

I have a Verizon Moto X Dev. Edition that I would like to use on T-Mobile network. So far I'm only able to get voice and data by disabling LTE and usting H+. Is there a way to use my XT1060 as a XT1053? in other words are the two models hardware different? or can i install the T-Mobile software and my phone so that I can use T-Mobile's LTE and have voice and data?

Thanks in advance for any help.

Best regards,

Rene

Please see the discussion in this thread -> Verizon Moto X on T-mobile
The Following User Says Thank You to KidJoe For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto X Q&A by ThreadRank