Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,660 Members 54,225 Now Online
XDA Developers Android and Mobile Development Forum

Verizon Moto X w/ Metro SIM, Voice & Data but no MMS/SMS

Tip us?
 
CraviingCritic
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Default Verizon Moto X w/ Metro SIM, Voice & Data but no MMS/SMS

As the title generally states, I've gotten my VZQ moto X set up with my MetroPCS SIM, and have encountered an issue.

If I don't use a manually entered APN, I get H+ signal, with voice and SMS, but no data.

If I use either the fast.metropcs.com or fast.t-mobile.com APNs, I get 4G LTE signal with data and voice, but no MMS.

Anyone know what the deal is?
 
samwathegreat
Old
#2  
samwathegreat's Avatar
Senior Member
Thanks Meter 507
Posts: 945
Join Date: Apr 2010

 
DONATE TO ME
Quote:
Originally Posted by CraviingCritic View Post
As the title generally states, I've gotten my VZQ moto X set up with my MetroPCS SIM, and have encountered an issue.

If I don't use a manually entered APN, I get H+ signal, with voice and SMS, but no data.

If I use either the fast.metropcs.com or fast.t-mobile.com APNs, I get 4G LTE signal with data and voice, but no MMS.

Anyone know what the deal is?
Have you input the MMSC url in your APN? I believe it should be:

MMSC URL: http://metropcs.mmsmvno.com/mms/wapenc


You HAVE to put in the http:// as well. Try this URL and advise if you can send MMS.
Remember: the "SEARCH" button will often save you a great deal of time waiting for a reply.

Help us keep XDA fun and safe. Please read the RULES, and please respect your fellow members.

I successfully CRACKED the SIM-LOCK on the Sprint XT1056 Moto X. Read about it HERE

Quote of the year:
Quote:
Originally Posted by doitinthedirt View Post
Well Google now doesn't work worth an iPhone. .I've spoken those last two lines ADB shell commands out loud for the past 15 minutes and I don't get root
 
CraviingCritic
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Quote:
Originally Posted by samwathegreat View Post
Have you input the MMSC url in your APN? I believe it should be:

MMSC URL: *Edited out because of <10 posts


You HAVE to put in the http as well. Try this URL and advise if you can send MMS.


That is what I have. Looking deeper into the forums, it seems the MotoX has issues with voice/MMS over LTE outside of the carrier the phone shipped from. I've now got my phone configured to stay on 3G/HSPA+ and everything seems to be working as it should. Still, it saddens me to not have LTE without sacrificing voice and MMS features. Hopefully a fix arises in the future.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes