Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,856 Members 47,385 Now Online
XDA Developers Android and Mobile Development Forum

[Q] VZW DEV 4.4 to 4.4.2 update failure opinion Question

Tip us?
 
Dburgessme2
Old
#1  
Dburgessme2's Avatar
Member - OP
Thanks Meter 6
Posts: 65
Join Date: Jan 2012
Default [Q] VZW DEV 4.4 to 4.4.2 update failure opinion Question

Hi all!

Just a quick synopsis. I've held off for a while. I've read just about everything related as it's come across here over the past few weeks.

I've been perfectly happy with where I sat:

VZW Dev Ed, Rooted, TWRP, xPosed, Tehter & Gravity Box modules.

I'm not fond of ADB commands, etc. but can work my way through them.

Today, I decided to to take a quick stab at things (a little differently).

So, here's what I did:

1) Unfroze some bloat
2) Unistalled xposed Framework
3) USED Flashify to backup my TWRP
4) USED Flashify to install stock recovery
5) Downloaded OTA
6) Installed 4.4.2 update
7) It FAILED

So, I restored my TWRP recovery through Flashify; re-installed xPosed Framework; refroze the bloat and I'm back to where I was before.

The only thing that I really think might have caused the update to fail was the fact that I had AOSP Browser installed. (with its related installer)

So, that's my question here....opinions...would that cause the update to fail?

I've since tried to uninstall that browser with the related installer but it keeps getting hung and force closes when trying.

Opinions? (other than..."please, use ADB commands")

I'm assuming flashing my system ui might take care of that?


Thanks for ideas. I know I'll take the time to get it done "proper". Just haven't been pressed to do it yet.
 
hlaalu
Old
#2  
hlaalu's Avatar
Senior Member
Thanks Meter 50
Posts: 401
Join Date: Nov 2007
Unfreeze everything and make sure the tether hack is reversed. I believe it tells you where it failed in recovery when it's doing its thing. I'm in the same boat as you, but I'm just going to wait until Moto releases the new image.
Nexus 10 ~ Moto X Dev Edition
I <3 Android Devs

Android Assault!
 
Dburgessme2
Old
#3  
Dburgessme2's Avatar
Member - OP
Thanks Meter 6
Posts: 65
Join Date: Jan 2012
Quote:
Originally Posted by hlaalu View Post
Unfreeze everything and make sure the tether hack is reversed. I believe it tells you where it failed in recovery when it's doing its thing. I'm in the same boat as you, but I'm just going to wait until Moto releases the new image.
Well, it's the tether module (not the hack)...so uninstalling xPosed would take care of that I'd think.

When Moto releases the new image...what's your plan? Able to flash that without losing data, etc?
 
Roland Stone
Old
#4  
Member
Thanks Meter 8
Posts: 70
Join Date: Mar 2010
Are you using the VZW specific stock recovery.img directly obtained from the Motorola website that you extracted yourself from the zip file you got there? I wouldn't necessarily trust any other stock recovery floating around.
 
Schaweet
Old
#5  
Senior Member
Thanks Meter 159
Posts: 628
Join Date: Aug 2010
Did you run the xposed cleaner zip or just uninstall it? It easier to just flash the system and recovery images via mfastboot. It takes two seconds assuming you have the Sdk installed and Moto drivers installed.

Sent from my Dev Edition Moto X
 
hlaalu
Old
#6  
hlaalu's Avatar
Senior Member
Thanks Meter 50
Posts: 401
Join Date: Nov 2007
Quote:
Originally Posted by Dburgessme2 View Post
Well, it's the tether module (not the hack)...so uninstalling xPosed would take care of that I'd think.

When Moto releases the new image...what's your plan? Able to flash that without losing data, etc?
Hmm double check that it checks for subscription when tethering to make sure it changed the files back?

I'm a little rusty with fastboot, but it doesn't wipe your data unless you ask it to:

Code:
Select Code
$ fastboot flash partition gpt.bin
$ fastboot flash motoboot motoboot.img
$ fastboot reboot-bootloader
$ fastboot flash logo logo.bin
$ fastboot flash boot boot.img
$ fastboot flash recovery recovery.img
$ fastboot flash system system.img
$ fastboot erase modemst1
$ fastboot erase modemst2
$ fastboot flash fsg fsg.mbn
$ fastboot reboot

$ fastboot erase userdata
$ fastboot erase cache

$ fastboot oem lock
So I think if you just don't do the fastboot erase userdata command your data is safe. I'll wait for someone with more experience to confirm that.

But even if that's not the case, I'll still wait because we have to fastboot for root and recovery anyways, might as well just do everything in one go.
Nexus 10 ~ Moto X Dev Edition
I <3 Android Devs

Android Assault!
 
Dburgessme2
Old
#7  
Dburgessme2's Avatar
Member - OP
Thanks Meter 6
Posts: 65
Join Date: Jan 2012
Quote:
Originally Posted by Schaweet View Post
Did you run the xposed cleaner zip or just uninstall it? It easier to just flash the system and recovery images via mfastboot. It takes two seconds assuming you have the Sdk installed and Moto drivers installed.

Sent from my Dev Edition Moto X
I only used the Uninstall from within itself. Where is the cleaner zip? Might have to do a search.

Thanks!

DB's Nexus 7
 
Dburgessme2
Old
#8  
Dburgessme2's Avatar
Member - OP
Thanks Meter 6
Posts: 65
Join Date: Jan 2012
Quote:
Originally Posted by Roland Stone View Post
Are you using the VZW specific stock recovery.img directly obtained from the Motorola website that you extracted yourself from the zip file you got there? I wouldn't necessarily trust any other stock recovery floating around.
Nope, I didn't extract it myself. I'll have to do that to make sure I've got the "real deal".

Thanks!

DB's Nexus 7
 
Schaweet
Old
#9  
Senior Member
Thanks Meter 159
Posts: 628
Join Date: Aug 2010
Quote:
Originally Posted by Dburgessme2 View Post
I only used the Uninstall from within itself. Where is the cleaner zip? Might have to do a search.

Thanks!

DB's Nexus 7
It's the xposed disabler zip that is put in the root of your SD card when you install xposed.

Sent from my Dev Edition Moto X
 
Dburgessme2
Old
#10  
Dburgessme2's Avatar
Member - OP
Thanks Meter 6
Posts: 65
Join Date: Jan 2012
Quote:
Originally Posted by Schaweet View Post
It's the xposed disabler zip that is put in the root of your SD card when you install xposed.

Sent from my Dev Edition Moto X
Just flash it through recovery I assume?

DB's Nexus 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Change the Alarm Icon in the Status Bar with Xposed

It’s hard to find a more hated object than your alarm clock. They wake us up nearly … more

Return to Outer Space Outer Space with Ship Up Game

Since the release of Flappy Birds, we’ve had the “fortune” to see … more

Device Review: OnePlus One

Seemingly every day, there are a bunch of new devices being released. Some are budget devices and some are … more

Browse the Internet with the Innovative Atlas Web Browser

For the most part, Chrome, Firefox, and Dolphin Browser have no real rivals among … more