Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SCRIPT - ROOT] Moto X Root Script (Locked Bootloader)

OP 640k

4th February 2014, 05:58 PM   |  #211  
Senior Member
Flag Charleston
Thanks Meter: 2
 
163 posts
Join Date:Joined: Oct 2010
More
So I have a question. Just got a Moto X from AT&T and it shipped with 4.2.2 software. What is the best method to root and keep root after ota?

Also what recovery can I use?

Coming from Verizon on HTC Droid DNA.

Thanks
5th February 2014, 03:45 AM   |  #212  
Senior Member
Thanks Meter: 12
 
239 posts
Join Date:Joined: Jun 2009
Also , when the 4.4.2 ota comes out, will root still be kept?
6th February 2014, 03:48 AM   |  #213  
Senior Member
Thanks Meter: 13
 
112 posts
Join Date:Joined: Oct 2011
More
I, for the LIFE of me, cannot root this phone.

Let me just type out the process I've gone through to see if anyone can see what I'm doing wrong.

1. Flash back to 4.2.2 camera using RSD or the manual fastboot flash xx method.
2. Skip setup, connect to WiFi
3. Go through RockMyMoto part of this script (doesn't seem to work for me anymore, all the steps complete, but SuperSU says the binary isn't installed).
4. I've already removed write protection, so I skip that step.
5. Flash back to clean 4.2.2 camera
6. Take OTA
7. Try using the install.sh (never works).

Am I doing something wrong? This just plain doesn't work anymore.
6th February 2014, 08:59 PM   |  #214  
stillthisguy's Avatar
Senior Member
Flag Omaha, NE
Thanks Meter: 428
 
619 posts
Join Date:Joined: Dec 2007
Donate to Me
More
Quote:
Originally Posted by Redjax

I, for the LIFE of me, cannot root this phone.

Let me just type out the process I've gone through to see if anyone can see what I'm doing wrong.

1. Flash back to 4.2.2 camera using RSD or the manual fastboot flash xx method.
2. Skip setup, connect to WiFi
3. Go through RockMyMoto part of this script (doesn't seem to work for me anymore, all the steps complete, but SuperSU says the binary isn't installed).
4. I've already removed write protection, so I skip that step.
5. Flash back to clean 4.2.2 camera
6. Take OTA
7. Try using the install.sh (never works).

Am I doing something wrong? This just plain doesn't work anymore.

I know you were being helped in the other thread, but just in case.

Since you already have WP removed

1. Flash back to clean 4.2.2 camera update
2. Do the first part of slapmymoto
3. Install 4.4
4. Do the last part of slapmymoto
5. After issuing the last 3 commands of slapmymoto, wait about 1 minute, then reboot
6. After reboot, install SuperSU from play store and update binaries.
7. Profit.
7th February 2014, 01:52 PM   |  #215  
Member
Thanks Meter: 26
 
48 posts
Join Date:Joined: Jun 2013
Hello,

Just received my XT1052, european MOTO X. How can I know if this script will work with it? I can't find any info online on this model, also don't know to which US edition could be comparable. Thanks in advance.
7th February 2014, 10:34 PM   |  #216  
Senior Member
Thanks Meter: 13
 
112 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by stillthisguy

I know you were being helped in the other thread, but just in case.

Since you already have WP removed

1. Flash back to clean 4.2.2 camera update
2. Do the first part of slapmymoto
3. Install 4.4
4. Do the last part of slapmymoto
5. After issuing the last 3 commands of slapmymoto, wait about 1 minute, then reboot
6. After reboot, install SuperSU from play store and update binaries.
7. Profit.

Ok, I've tried this literally 15 times in the past couple days, and on the last step, I always get stuck with "/system/bin/sh: can't create /sys/kernel/uevent_helper: Permission Denied."

I have tried rooting this device every possible way I can find on the Internet; I've used the official SlapMyMoto post, I've been pointed to a Reddit thread, I've used a theUnlockr guide, I've watched YouTube videos, I've followed steps users have given me to try, and I've tried a few "SlapMyMoto didn't work? Try this" threads, with ABSOLUTELY NO LUCK. This device is driving me absolutely nuts, I'm ready to stomp on it with all the force I can send through my leg. All I want is root access. Is there anything else I can try before just giving up and selling it, and getting a different device that actually works?
7th February 2014, 11:42 PM   |  #217  
stillthisguy's Avatar
Senior Member
Flag Omaha, NE
Thanks Meter: 428
 
619 posts
Join Date:Joined: Dec 2007
Donate to Me
More
Quote:
Originally Posted by Redjax

Ok, I've tried this literally 15 times in the past couple days, and on the last step, I always get stuck with "/system/bin/sh: can't create /sys/kernel/uevent_helper: Permission Denied."

I have tried rooting this device every possible way I can find on the Internet; I've used the official SlapMyMoto post, I've been pointed to a Reddit thread, I've used a theUnlockr guide, I've watched YouTube videos, I've followed steps users have given me to try, and I've tried a few "SlapMyMoto didn't work? Try this" threads, with ABSOLUTELY NO LUCK. This device is driving me absolutely nuts, I'm ready to stomp on it with all the force I can send through my leg. All I want is root access. Is there anything else I can try before just giving up and selling it, and getting a different device that actually works?

Since you have listed everything else, you could try my toolkit. Have had a lot of people report that it worked for them. After installing, choose option 11, make sure you have the correct files in the correct folders, then choose option 1. Answer the first question No, then answer the second question Yes. If you run into any issues you can comment in my thread as well.
10th February 2014, 11:48 PM   |  #218  
Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Jul 2009
How can I undo the changes generated by this script?
Used this script on T-mobile version, bootloader locked

No luck, did not gain root access, I believe, because had issues with telnet as other users have had. Back on 4.4 now

Would like to:

1) Accept the latest OTA (Blur_Version.161.44.25.ghost_row.Retail.en.US.zip ) - installation aborts!

Tried installing the OTA manually however when in Recovery, when verifying current system, get error '"/modem/image/dsps.b00" has unexpected contents. Installation aborted


2) Install apps NOT from Play store, but can't because entering security tab is now impossible




Is it possible to fix this by completely restoring the original state of the phone somehow? Thanks.
Last edited by razmalai; 11th February 2014 at 06:36 AM. Reason: error originally listed 4.2.2 when version is 4.4
18th February 2014, 12:19 PM   |  #219  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2009
"Moto X factory image was NOT found" and yet it's right there, in the folder, downloaded from the link in the OP. I've tried changing the filename etc but still the same error. EU Moto XT1052.

Any ideas anyone please?
23rd February 2014, 05:51 AM   |  #220  
Member
Thanks Meter: 6
 
52 posts
Join Date:Joined: Dec 2010
I was having issues with Telnet and I think it had to do with the Telnet server not being installed in windows. Make sure you go to Control Panel, Programs, Turn Windows Features On and OFF and Make sure BOTH telnet folders are selected.

The Following User Says Thank You to Flexia32 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
moto x, root, toolkit, xt10
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes