Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[APP] Moto X/G/E boot logo command line tool

OP marmottepoilue

13th August 2014, 01:04 PM   |  #21  
Junior Member
Thanks Meter: 42
 
28 posts
Join Date:Joined: Jul 2013
Donate to Me
More
I peeked into the gpt.bin from stock firmware for moto x and moto e, and also confirmed, that like the moto g, the max logo.bin size is 4MB. As such, it may be a good idea to at least warn, if not error out, if the 4MB is exceeded.
3rd October 2014, 07:41 PM   |  #22  
Member
Flag Davisville
Thanks Meter: 2
 
62 posts
Join Date:Joined: Jan 2013
More
after I flashed one of the bins I just get a Greenish Brown screen with a Square in the middle(about the size of the <3% battery image) with random colored horizontal lines, Then it flashes the Original Boot logo for a frame, then the screen is black until fully booted. Even flashing the original logo.bin won't fix this.
4th October 2014, 11:01 AM   |  #23  
marmottepoilue's Avatar
OP Junior Member
Thanks Meter: 25
 
12 posts
Join Date:Joined: Jul 2014
Hi Biom4st3r,

What's your phone ?
What's your android version ?
Where do you get your 'bins' ?
Where do you get your original logo.bin ?
4th October 2014, 04:42 PM   |  #24  
KidJoe's Avatar
Recognized Contributor
Flag Thorndale/Romansville, PA
Thanks Meter: 907
 
2,172 posts
Join Date:Joined: Aug 2008
More
Quote:
Originally Posted by Biom4st3r

after I flashed one of the bins I just get a Greenish Brown screen with a Square in the middle(about the size of the <3% battery image) with random colored horizontal lines, Then it flashes the Original Boot logo for a frame, then the screen is black until fully booted. Even flashing the original logo.bin won't fix this.

I've seen others post this...

A few times it was from Safestrap users. Because they had safestrap, their bootloader and GPT.BIN was older, and was expecting a LOGO.BIN in the older format. If that is your situation, and you want to continue using Safestrap, you need to use LOGO.BIN files formatted for 4.2.2 phones.

If you had used Safestrap, but no longer use it, re-flash the full stock SBF of the ROM currently on your phone to bring all files in line...

Next, there was a user who could not use mfastboot to flash a logo.bin (no error was given, but he got a messed up graphic each time he booted). He was able to use a flashable zip and install via custom recovery. Try this if you have TWRP installed on your phone, download -> http://mark.cdmaforums.com/X-STUFF/P...-flashable.zip and boot to TWRP and try to install the ZIP. I don't recall what finally fixed it for him.

Lastly there was a user who got the messed up graphic using either mfastboot or the flashable zip. He had to reflash the SBF of the rom on his phone in order to fix.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes