Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Motorola MB526 shuts down mid start-up

OP TheGuyThatNeedsALotOfHelp

4th September 2014, 12:38 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Sep 2014
Okay um I don't know if this is the right place to be so sorry if its wrong. My phone when oi got it from my sister was incredibly slow so I decided to so a factory reset to see if that would work, I did alittle but not a lot. After awhile of not using my phone being away on holiday and everything so I haven't used it in about 5-6 weeks, I turned it on after I charged it for a bit and I know it was charging because of the white LED that lights up when charging but when I wen to turn it on it gets past the Motorola logo then to the T with the blue background logo and then shuts off and doesn't properly start up. My father suggested I get a new battery for it but I don't know if it will fix the problems. Any ideas? Help?
6th September 2014, 12:01 PM   |  #2  
thekguy's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 247
 
835 posts
Join Date:Joined: Nov 2009
More
Do a factory reset + cache wipe from stock recovery once. If it doesn't work, then use rsdlite to flash an sbf (refer to the defy beginners guide for step by step instructions)

Sent from my Nexus 5 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes