Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,035 Members 40,778 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Emulators laggy when plugged into HDMI out

Tip us?
 
DallasW
Old
#1  
Member - OP
Thanks Meter 0
Posts: 35
Join Date: Sep 2008
Default [Q] Emulators laggy when plugged into HDMI out

Hey there, As the title states, just wanting to do some emulator game playing on my TV and figured my Nexus 10 would work great.

I got the bluetooth controllers up and running pretty easily, and the games run great on the tablet itself, but when I pop in the HDMI cable the FPS immediately drops (especially on N64 games) and the games become borderline unplayable. Unplug the HDMI cable mid game and everything is back to normal. I assume this has something to do with scaling to two different resolutions, but I'm not sure if there is some fix/workaround (either turning off the tablet display or scaling the tablet display maybe?). Any recommendations would be great!
 
XxLordxX
Old
#2  
XxLordxX's Avatar
Recognized Contributor
Thanks Meter 1,036
Posts: 2,811
Join Date: Jul 2011
Location: Why do you need to know that?

 
DONATE TO ME
Hi,

I face this same issue with NOVA launcher, it works okay on tablet, but when on HDMI it gets very laggy. I don't know a solution, however you might want to still try changing screen's resolution, to do as such, type on a terminal emulator:
Code:
su
wm size 1920x1080 (I'm assuming you have a FullHD TV)
wm density 220
This will change the resolution of your tablet screen, if you want to go back, type:
Code:
su
wm size reset
wm density reset
Good luck,
~Lord

"Time is too short to cry, long enough to try." - March of Time (Helloween)
Sent from my KitKat Nexus 10
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes