FORUMS

Analysis & Opinion

Annoying sound

41 posts
Thanks Meter: 2
 
By Jiddeee, Member on 23rd April 2014, 02:43 PM
Post Reply Subscribe to Thread Email Thread
8th February 2015, 09:39 PM |#21  
bbeanss's Avatar
Senior Member
Flag Coventry
Thanks Meter: 166
 
More
From my experience with this problem (had it on my Xperia Z and Nexus 4) it's to do with the minimum/maximum screen off frequency being too low, the phone will drop to that frequency while sleeping and it won't be a high enough frequency to run the app properly which inevitably leads to the 'buzzing' or 'glitchy' noise that you hear during screen off playback.

This is just how I resolved the stuttering that was occurring on my phones and for all I know the guys on this thread could well be suffering from a completely unrelated issue, but all you need to do is increase your screen off frequency (On my Nexus I only do this to core 0, I keep cores 1, 2 & 3 at 81mhz) to 162mhz and the stuttering should all but disappear (I still get the occasional buzz here and there but I'm a battery saving freak so I put up with it)

Hope I helped guys!

Beans
The Following 2 Users Say Thank You to bbeanss For This Useful Post: [ View ]
 
 
9th February 2015, 12:12 PM |#22  
Senior Member
Thanks Meter: 85
 
More
guys after reading bbeanss post i experimented a little.

i set minimum frequency 594 mhz and i had the sound.
after that i set 702mhz minimum frequency and the sound disapeared. i am using simple aosp and franco kernel.
9th February 2015, 01:14 PM |#23  
bbeanss's Avatar
Senior Member
Flag Coventry
Thanks Meter: 166
 
More
Quote:
Originally Posted by ttheodorou

guys after reading bbeanss post i experimented a little.

i set minimum frequency 594 mhz and i had the sound.
after that i set 702mhz minimum frequency and the sound disapeared. i am using simple aosp and franco kernel.

It may well have something to do with undervolting and governor on each core as well so have a play around with those settings in Synapse/TricksterMod.

I wouldn't recommend having your CPU running at 40%~ continuously though (unless it's only core 0 that you're applying this to?) because it'd be a massive cause of battery drain! Try instead setting the cores up like this:

Quote:

Using Unleashed 101u & Synapse

Core - Minimum Frequency - Governor

Core 0 - 270mhz -Intellidemand
Core 1 - 162mhz - Intellidemand
Core 2 - 162mhz - Conservative
Core 3 - 81mhz - Conservative

Max screen off freq - 810mhz

With a global undervolt of -100mV

I seem to get pretty good results using this setup!

Beans
Last edited by bbeanss; 9th February 2015 at 01:17 PM.
9th February 2015, 01:20 PM |#24  
Senior Member
Thanks Meter: 85
 
More
Quote:
Originally Posted by bbeanss

It may well have something to do with undervolting and governor on each core as well so have a play around with those settings in Synapse/TricksterMod.

I wouldn't recommend having your CPU running at 40%~ continuously though (unless it's only core 0 that you're applying this to?) because it'd be a massive cause of battery drain! Try instead setting the cores up like this:



I seem to get pretty good results using this setup!

Beans

i have undervolt -100mV. my kernel support minimum freq 384mhz and i had the problem. i made custom profile when i open google music to 702mhz minimum freq and everything is good for me
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes